# 1024 MB trotzdem "Allowed memory size of 536870912 bytes exhausted"

**URL:** https://forum.shopware.com/t/1024-mb-trotzdem-allowed-memory-size-of-536870912-bytes-exhausted/91869
**Category:** Installation / Einstieg
**Created:** [8. Dezember 2021 um 13:29 UTC](https://forum.shopware.com/t/1024-mb-trotzdem-allowed-memory-size-of-536870912-bytes-exhausted/91869 "2021-12-08T13:29:44Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![webarbeit](https://avatars.discourse-cdn.com/v4/letter/w/b487fb/32.png) [@webarbeit](https://forum.shopware.com/u/webarbeit)
#### Post date: [8. Dezember 2021 um 13:29 UTC](https://forum.shopware.com/t/1024-mb-trotzdem-allowed-memory-size-of-536870912-bytes-exhausted/91869/1 "2021-12-08T13:29:44Z")

</div>

Hallo,

laut Anzeige bei der Installation und phpinfo habe ich 1024 MB als memory\_limit.

Trotzdem erscheinen folgende Fehler im Log:

```auto
[2021-12-08T13:18:09.651173+00:00] php.CRITICAL: Fatal Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 1515520 bytes) {"exception":"[object] (Symfony\\Component\\ErrorHandler\\Error\\OutOfMemoryError(code: 0): Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 1515520 bytes) at /www/htdocs/xyz/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOStatement.php:262)"} []

```

Versteht jemand den Zusammenhang?

Viele Grüße und Danke vorab,  
Frank

---

<div class="post-metadata">

### Author: ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)
#### Post date: [8. Dezember 2021 um 15:24 UTC](https://forum.shopware.com/t/1024-mb-trotzdem-allowed-memory-size-of-536870912-bytes-exhausted/91869/2 "2021-12-08T15:24:09Z")

</div>

Die Fehlermeldung (`536870912 bytes`) sieht mir danach aus, als ob Du noch 512MB Memory-Limit eingestellt hast statt 1024MB. Das solltest Du prüfen, ggf. musst Du auch den PHP-Prozess einmal neu starten.

[![logo_timme_hosting_200x61_trans](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/c/c058b19445ae66a8db8d4b25b7e2d36ff56dd1ea.png)](https://timmehosting.de/)

---

<div class="post-metadata">

### Author: ![webarbeit](https://avatars.discourse-cdn.com/v4/letter/w/b487fb/32.png) [@webarbeit](https://forum.shopware.com/u/webarbeit)
#### Post date: [8. Dezember 2021 um 15:58 UTC](https://forum.shopware.com/t/1024-mb-trotzdem-allowed-memory-size-of-536870912-bytes-exhausted/91869/3 "2021-12-08T15:58:03Z")

</div>

Das sollte eigentlich passen:

 ![image](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/5/50918b2fc991950788ff727007ee66f28d44e66a.png)

---

<div class="post-metadata">

### Author: ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)
#### Post date: [8. Dezember 2021 um 16:09 UTC](https://forum.shopware.com/t/1024-mb-trotzdem-allowed-memory-size-of-536870912-bytes-exhausted/91869/4 "2021-12-08T16:09:19Z")

</div>

Ist es eventuell möglich, dass die Fehlermeldung aus dem Log durch einen Cronjob aus der Kommandozeile ausgelöst wird, der möglicherweise mit einem abweichenden PHP-Memory-Limit ausgeführt wird?  
[![logo_timme_hosting_200x61_trans](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/c/c058b19445ae66a8db8d4b25b7e2d36ff56dd1ea.png)](https://timmehosting.de/)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)
