sawoschsawosch MemberComments: 21 Received thanks: 0 Member since: June 2014

Hallo :)

Mein Provider stellt PHP 7.0 nur noch bis November 2018 zur Verfügung, danach müsste die Seite auf 7.2 umgestellt werden. Gemäss diesem Artikel ist mir allerdings nicht klar ob und wann dies seitens Shopware möglich sein wird und ich habe auch keine genaueren Informationen diesbezüglich gefunden.

Wie sieht der aktuelle Stand aus?

1 Answer

  • ShyimShyim MemberComments: 831 Received thanks: 335 Member since: May 2015

    Hey @sawosch‍,

    mit 5.5 ist der Ioncube Loader nicht mehr notwendig dann kannst du dir eine Version zwischen PHP 5.6 - 7.2 aussuchen Halo

    Quote
    Accepted Answer
    Thanked by 1sawosch
  • Accepted Answer

Answers

  • drakondrakon MemberComments: 934 Received thanks: 264 edited August 2018 Member since: February 2014

    Ich würde mich von meinem Provider nicht so unter Druck setzen lassen und zu einem guten Provider (bsp. Timmehosting) umziehen, der auch nicht ganz so frische PHP-Versionen unterstützt (php 7.0 ist ja jetzt noch nicht am Ende der Unterstützung angekommen). Hier wälzt jemand Arbeiten, dier er selbst zur Sicherheit des eigenen Angebots machen müßte, auf seine Kunden ab.

    Thanked by 1sawosch
  • ShyimShyim MemberComments: 831 Received thanks: 335 Member since: May 2015

    Hey @sawosch‍,

    mit 5.5 ist der Ioncube Loader nicht mehr notwendig dann kannst du dir eine Version zwischen PHP 5.6 - 7.2 aussuchen Halo

    Quote
    Accepted Answer
    Thanked by 1sawosch
  • drakondrakon MemberComments: 934 Received thanks: 264 Member since: February 2014

    Hallo,

    mit 5.5 ist der Ioncube Loader nicht mehr notwendig dann kannst du dir eine Version zwischen PHP 5.6 - 7.2 aussuchen

    sobald es alle nötigen Plugins in einer angepassten und für 5.5 frei gegebenen Version gibt. Bin da noch ein wenig skeptisch, wie sich die Plugin-Anbieter verhalten werden. 

    Thanked by 1sawosch
  • sawoschsawosch MemberComments: 21 Received thanks: 0 Member since: June 2014

    Hey @sawosch‍,

    mit 5.5 ist der Ioncube Loader nicht mehr notwendig dann kannst du dir eine Version zwischen PHP 5.6 - 7.2 aussuchen Halo

    Heisst das, dass ich mit der neuesten Version 5.5 keine PHP Probleme mehr habe, ausser mit den Plugins? Bei den Plugins habe ich eigentlich nur das von PayPal installiert. Kann man davon ausgehen, oder weiss man sogar, ob dieses App von der neuen Version unterstützt wird? 

     

    @Drakon, mit meinem Provider bin ich eigentlich sehr zufrieden, Support und Dienstleistungen stimmen. Er hat mir soeben mitgeteilt dass sie sich an die EOL Verordnung zwecks möglicher Sicherheitslücken halten werden, was ich natürlich auch verstehe. 7.0 war wohl nur eine Beta, 7.1 würden sie noch ein Jahr supporten. Das die PHP Version EOL geht weiss man ja auch schon eine Zeit, daher bin ich mir mit deiner Aussage über die Abwälzung der Arbeit nicht sicher, aber um das zu beurteilen seh ich zu wenig hinter die Kulissen

  • sawoschsawosch MemberComments: 21 Received thanks: 0 Member since: June 2014

    Ich push mal eben nach oben. :)

  • Michael TelgmannMichael Telgmann ModeratorComments: 937 Received thanks: 273 Member since: June 2014

    Hallo @sawosch

    jedes Plugin, dass mit Shopware 5.5 kompatibel ist, ist automatisch NICHT mehr verschlüsselt. D.h. der IonCube Loader ist komplett überflüssig und wie shyim schon sagte, kannst du dir dann die PHP Version aussuchen. Unser PayPal Plugin ist natürlich voll kompatibel. Wenn du also sonst keine Plugins installiert hast, solltest du keine Probleme bekommen. 

    Viele Grüße aus Schöppingen

    cool Michael Telgmann

    Thanked by 1sawosch
  • sawoschsawosch MemberComments: 21 Received thanks: 0 Member since: June 2014

    Danke für die rasche Bestätigung. Wann wird die Finale 5.5 erscheinen?

  • Michael TelgmannMichael Telgmann ModeratorComments: 937 Received thanks: 273 Member since: June 2014

    Bald Wink

    Thanked by 1sawosch
  • simplybecausesimplybecause MemberComments: 1660 Received thanks: 228 Member since: January 2012
    Unser PayPal Plugin ist natürlich voll kompatibel. Wenn du also sonst keine Plugins installiert hast, solltest du keine Probleme bekommen. 

    Ihr habt ja verschiedene PayPal-Plugins.
    Werden alle mit der 5.5 kompatibel sein?

  • Michael TelgmannMichael Telgmann ModeratorComments: 937 Received thanks: 273 Member since: June 2014

    nein, nur noch unser neustes Plugin ( https://store.shopware.com/swag828732772311f/paypal.html ), dass alle anderen ersetzt. 

    Viele Grüße aus Schöppingen

    cool Michael Telgmann

  • SKBSKB MemberComments: 156 Received thanks: 4 Member since: October 2012

    Hi zusammen,

    ich hänge an dem PHP7.2 punkt gerade ebenso, mein provider möchte zum Dezember hin auf 7.2 alle Server einstellen. 

    Bei mir scheitert es gerade an 7.2 ich weiß nur aktuell noch nicht warum

    SW Version 5.5.2 und Plugins siehe Screenshots, hab so viele es geht deaktiviert aber irgend eines scheint noch verschlüsselt zu sein oder? Kann mir hier jemand einen Tipp geben?

  • SebastianKlöpperSebastianKlöpper AdministratorsComments: 7196 Received thanks: 1674 Member since: June 2010

    Hi,

    deinstallieren reicht grundsätzlich nicht aus, da die Dateien dann ja noch auf dem System sind.

    Verschlüsselte Plugins müssen deinstalliert und dann gelöscht werden, wenn es keine 5.5 kompatible quelloffene Version gibt.

    Sebastian

    PS: Lizenz-Manager muss ebenfalls gelöscht werden

  • ShyimShyim MemberComments: 831 Received thanks: 335 Member since: May 2015

    Alle inaktiven / deinstallierten müssen auch unverschlüsselt sein

  • SKBSKB MemberComments: 156 Received thanks: 4 Member since: October 2012

    Ok danke Euch, dann mach ich mich ran mit dem rauslöschen.

  • MobalaMobala MemberComments: 7 Received thanks: 0 Member since: December 2016

    Hallo Leute,

    irgendwie stecke ich im ähnlichem Problem fest. Habe jetzt zwar die Aktualisierung auf 5.5.3 hinbekommen, allerdings sehe ich leider noch nicht so richtig durch wo und was noch entfernt / geändert werden muss, damit der Shop in PHP 7.2 läuft.

    Wie und wo kann ich schauen, welche Plugins bleiben dürfen und welche gelöscht werden müssen ? da ein "deaktivieren" ja keine Punkte bringt.

    Mag mir hier ggf. einer helfen ?

    Dankende Grüße
    Jasmin

  • sschreiersschreier MemberComments: 2941 Received thanks: 791 edited November 2018 Member since: August 2014

    Hallo,

    man sieht nicht direkt irgendwo im Shopware Backend, ob ein Plugin verschlüsselt ist oder nicht. Am einfachsten wäre es wahrscheinlich, einfach in den Shopware Account unter "Lizenzen" -> "Lizenzen" zu gehen und dort alle Plugins einmal aufzurufen (also mit dem Link auf dem Community Store), auf der entsprechenden Seite im Community Store sieht man dann sofort, ob das Plugin verschlüsselt ist oder nicht.

    Andernfalls kann man sich auch per FTP auf den Server verbinden und dann unter "engine/Shopware/Plugins/Community/" und "custom/plugins" die jeweiligen PHP - Dateien der Plugins ansehen und so direkt erkennen, ob das jeweilige Plugin verschlüsselt ist oder nicht.

    Grüße

    Sebastian

  • MobalaMobala MemberComments: 7 Received thanks: 0 Member since: December 2016

    Hallo,

    Danke für den Hinweis.

    Werde dort mal alles durchsuchen und ggf. durch löschen oder Updaten überarbeiten.

    Wenn die verschlüsselten dann im backend gelöscht sind reicht das ?

    Gruß Jasmin

  • sschreiersschreier MemberComments: 2941 Received thanks: 791 edited November 2018 Member since: August 2014

    Hallo Jasmin,

    am sichersten (und ja auch am sinnvollsten) ist das Löschen des kompletten, verschlüsselten Plugins. Andernfalls kannst du ja auch beim Hersteller des jeweiligen Plugins erstmal nachfragen, ob eine unverschlüsselte Variante geplant ist - andernfalls müsstest du im Community Store nach einer Alternative für das Plugin suchen. Den "Lizenz Manager" von Shopware musst du auch löschen, da dieser nicht mehr benötigt wird und ja auch verschlüsselt ist - alle anderen Plugins von Shopware selbst können auf jeden Fall bleiben, die sind auf keinen Fall verschlüsselt.

    Grüße

    Sebastian

  • SBSB MemberComments: 104 Received thanks: 63 Member since: April 2015

    und nicht vergessen: auch der lizenzmanager muss raus wenn du php 7.2 nutzen möchtest (oder musst)

  • MobalaMobala MemberComments: 7 Received thanks: 0 Member since: December 2016

    hmm, aus meiner Sicht sind alle Plugins die jetzt noch da sind unverschlüsselt und auch aktuelle Version.

    Der Lizenzmanager ist auch nicht mehr im Backend zu finden.

    Dennoch funktioniert der Shop in PHP 7.2 nicht. ( zumindest sagt mir der Browser Error 500 - Seite nicht verfügbar )

    Wo hab ich was über sehen ?

  • SBSB MemberComments: 104 Received thanks: 63 Member since: April 2015

    schau mal in deine logfiles. vermutlich ist noch ein plugin aktiv welches den ioncube loader benötigt den du mit php 7.2 / shopware halt nicht mehr verwenden kannst

    lg

  • MobalaMobala MemberComments: 7 Received thanks: 0 Member since: December 2016

    Ahhh nun läufts, einmal Cache leeren und neuladen, schon gehts. ( schaut zumindest derzeit so aus )

    Habt Herzlichen DANK für eure Hilfe.

    Gruß Jasmin

Sign In or Register to comment.