soigroegsoigroeg MitgliedKommentare: 175 Danke erhalten: 4 Mitglied seit: August 2012 bearbeitet Juni 2015
Shopware scheint eine gute Software zu sein.

Da ist es wirklich schade, dass die Schwierigkeiten bereits bei der Installation beginnen.

Ich versuche Shopware 4.0 auf meinem Webspace auf DomainFactory zu laden. Bisher ohne Erfolg, obwohl ich mich an die Installationsanleitung halte.

Anleitung TL;DR:
1. Besorg dir einen Shopware kompatibeln Hoster - z.B. DomainFactory
2. Lade das Installationspaket per FTP im "Binary-Modus" auf den Hoster
3. Steuere deine Domain an und gib weitere Informationen ein.

Zu Punkt 3 kommt es erst gar nicht, weil davor schon ein "Internal Server Error 500" auftaucht. Komplette Fehlermeldung heißt so:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Hat jemand einen Link zu einem Lösungstutorial? Würde wirklich ungern zurück zu Magento wechseln. Obwohl ich Magento bereits zum Laufen gebracht habe: Proof!

gruß,

Georg

Kommentare

  • XXXXXXXXXXXX MitgliedKommentare: 638 Danke erhalten: 10 Mitglied seit: Dezember 2010
    Hi, bei mir das gleiche Problem. Kann's an der .htaccess liegen?

    Viele Grüße
    Rainer
  • soigroegsoigroeg MitgliedKommentare: 175 Danke erhalten: 4 Mitglied seit: August 2012
    Hallo,

    Schön dass ich nicht der Einzige bin.

    Ich habe versucht ein SystemCheck auszuführen, indem ich die "check.php" auf meinen Hoster geladen habe. Der Versuch die check.php auszuführen, brachte nur die gleiche Fehlermeldung.

    http://saasil.internetshop.cc/check.php

    Dann habe ich versucht, die .htaccess Providerbedingt anzupassen, nach diesem Tutorial:
    http://wiki.shopware.de/Installation-3.5.0_detail_518.html#Installation_domainFACTORY

    .htaccess angepasst (indem die Zeile "RewriteBase /" an die richtige Stelle hinzugefügt wurde), aber trotzdem keine Veränderung.

    Also ich tippe, es liegt entweder an der .htaccess- oder an der php.INI-Datei. Aber ich hatte absolute keine Ahnung, dass man Informatik studieren muss, um Shopware zu benutzen. :(

    EDIT: check.php brachte folgendes Ergebnis:
    iFy1d.jpg
    6f37G.jpg
    loFVj.jpg
    ZmCIe.jpg

    Also im Grunde keine Informationen...
  • soigroegsoigroeg MitgliedKommentare: 175 Danke erhalten: 4 Mitglied seit: August 2012
    PROBLEM GELÖST!

    Domainfactory will, dass der UPLOAD einer Webseite in einem Unterverzeichnis erfolgt.
    Domainfactory hat dafür das Verzeichnis /webseiten, in dass alle Webseiten rein sollen.

    Ich hatte per FTP vor dem Upload alle Verzeichnisse gelöscht und die Daten einfach in das Hauptverzeichnis übertragen.

    Glücklicherweise haben die im Support den Fehler erkannt und behoben, so dass ich mit der Installation weitermachen kann.

    Nächstes Problem wäre:
    Database-Error!: SQLSTATE[HY000] [1045] Access denied for user 'db371160'@'localhost' (using password: YES)
    ??? Jemand eine Idee?


    EDIT2: Auch das Problem gelöst. Localhost ist bei DF falsch. Der Datenbankserver ist nicht localhost sondern mysql5.deinewebseite.de (Abhängig von der mysql Version)
  • SeraphineSeraphine MitgliedKommentare: 78 Danke erhalten: 3 Mitglied seit: August 2012
    Hallo,

    ich habe fast den gleichen Fehler nach Eingabe des Lizenzschlüssels:

    Database-Error!: SQLSTATE[28000] [1045] Access denied for user 'xxxxxxxx'@'localhost' (using password: NO)

    Wie hast du das Problem gelöst, das verstehe ich nicht ganz?:
    EDIT2: Auch das Problem gelöst. Localhost ist bei DF falsch. Der Datenbankserver ist nicht localhost sondern mysql5.deinewebseite.de (Abhängig von der mysql Version)
  • BigBangDEBigBangDE MitgliedKommentare: 1 Danke erhalten: 0 Mitglied seit: März 2013
    Hallo Leute,

    wir haben leider das gleiche Problem.

    Database-Error!: SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost'

    Wir haben Shopware in unseren lokalen XAMPP Ordner unter C:xampp/htdocs/testshop
    entpackt und über localhost/testshop/install.php den Installations-Wizzard aufgerufen.

    Leider kommen wir über den Punkt 3 der Installation nicht hinweg, da immer wieder dieser Fehler auftaucht.

    Database-Error!: SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost'

    Wir haben seinerzeit bei der Installation von Xampp bei unserer Datenbank den Benutzer-Namen "root" ausgewählt, jedoch nie ein Password vergeben.

    Auch dort verlangt Shopware zwingend die Auswahl eines Passwortes.
    Wie lösen wir dieses Problem?

    Ich danke euch schon jetzt für eure Tipps und Vorschläge.

    Liebe Grüße
  • Dennis WahlDennis Wahl MitarbeiterKommentare: 500 Danke erhalten: 94 Mitglied seit: Dezember 2012
    Hi BigBangDe,

    für eine Shopware Installation muss der user für die entsprechende Datenbank zwingend ein Passwort haben.
    Dies können Sie für den User root einfach in den Einstellungen von PhpMyAdmin vergeben.

    Gruß

    Dennis
  • shopusershopuser MitgliedKommentare: 126 Danke erhalten: 4 Mitglied seit: September 2012
  • ToddTodd MitgliedKommentare: 4 Danke erhalten: 0 Mitglied seit: März 2014
    Hallo,
    ich habe dieselben Probleme wie BigBangDE.
    Habe eine interne Installation mit XAMPP vor und komme nicht über Step 3 hinweg, weil die Fehlermeldung >Database-Error!: SQLSTATE[HY000] [1045] Access denied for user 'xxx'@'localhost' (using password: YES< kommt.
    Allerdings habe ich über phpMyAdmin der Datenbank einen User mit Passwort vergeben. Trotzdem wird mir der Zugriff verweigert. Auch der root-User mit Passwort geht nicht.
    Wenn ich bei Datenbank Socket localhost eintrage, bekomme ich diese Fehlermeldung: >Database-Error!: SQLSTATE[HY000] [2002] No such file or directory<
    Da ich am Mac arbeite, habe ich es auch mit Mamp 3.0 versucht. Das bringt bei der Installation aber keinen Unterschied. Auch hier gibt es die gleiche Fehlermeldung.

    Weiß jemand Rat?
  • Mario BöltMario Bölt MitgliedKommentare: 120 Danke erhalten: 18 Mitglied seit: April 2012
    Bitte vergib für den lokalen Root-User unter XAMP mal ein Passwort.
  • cschoencschoen MitgliedKommentare: 1 Danke erhalten: 0 Mitglied seit: März 2015
    Ich habe ein ähnliches Problem.

    Bei Step 5 - Auswahl der Lizenz (Community Edition) zur Vorbereitung einer Migration von XTC auf Shopware und Aufbau von Know-How innerhalb des Unternehmens selber, wollen wir erst einmal ein paar Dinge vor der Migration klären.

    Bei der Lizenzauswahl kommt nun aber folgender Fehler:

    Database-Error!: SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: NO)

    Die Datenbank ist bereits komplett angelegt und in so fern scheint das eigentlich zu funktionieren.

    Gibt es eine Idee dazu?
  • sjtecsjtec MitgliedKommentare: 18 Danke erhalten: 0 Mitglied seit: Juni 2015
    Hallo zusammen,

    hatte heute ebenfalls das Problem mit den hier beschriebenen Fehlermeldungen. Leider wurde hier aber nie die Lösung derjenigen gepostet, die die Probleme hatten. Daher will ich das mal tun:

    Ich steige in der Installationsroutine beim System-Check ein. Den ionCube-Loader habe ich vernachlässigt. Los geht's:

    Als erstes gab es nicht erfüllte Serveranforderungen:
    "memory_limit" und "upload_max_filesize"

    Wie man das über die htaccess ändern kann, ist im Post von Grazzy beschrieben:
    Grazzy schrieb:
    hi

    Jup ist es.

    ich hatte zu Anfang ein paar Probleme aber der Support hat wirklich super geholfen.


    Einmal am Anfang
    #zum arbeiten mit PHP als CGI
    AddHandler php5-cgi .php
    
    einfügen und fast ganz unten bei
    php_value memory_limit 128M
    
    die # davor entfernen.

    Gruß Grazzy
    Danach geht es in der Installationsroutine mit der Datenbank weiter. Wie ihr diese unter XAMPP Lokal anlegt seht ihr hier im Video.

    Ihr solltet auch für den XAMPP Root User ein Passwort vergeben. Das hat zur Folge, dass ihr euch bei phpMyAdmin dann mit Benutzernamen und Passwort anmelden müsst. Dazu nutzt ihr folgenden Link: [url=http://localhost/security/xamppsecurity.php]http://localhost/security/xamppsecurity.php[/url].

    Wenn ihr euch dann in phpMyAdmin anmelden wollt, nutzt ihr "root" als Benutzernamen und eurer gewähltes Passwort.

    In der Shopware-Installationsroutine müsst ihr dann folgende Daten für die Verbindung mit der MySQL-Datenbank eingeben:

    Datenbank-Server: localhost
    Datenbank-Port: 3306
    Datenbank Socket (optinal): "Hier musst du nichts eintragen!"
    Datenbank Benutzer: root
    Datenbank Passwort: "Dein für die Datenbank gewähltes Passwort (nicht das Passwort für den Root User!)"
    Datenbank Name: "Hier den Namen deiner Datenbank eintragen, die du Anfangs erstellt hast!"

    Danach sollte es normal weitergehen. Viel Erfolg! ;)

    Gruß
    Shab
Anmelden oder Registrieren, um zu kommentieren.