DIFAOMDIFAOM MemberComments: 1 Received thanks: 0 Member since: September 1 edited September 15

Guten Abend Zusammen,

nach dem Umzug von einem kleinen Shop von Shopware 5 auf 6 ist im Frontend ein "500 Internal Server Error".

Im Shopware Debugmodus habe ich folgende meldungen:

 

CRITICAL19:16:08

php

Uncaught Error: Argument 6 passed to Shopware\Core\System\SalesChannel\SalesChannelContext::__construct() must be an instance of Shopware\Core\Checkout\Customer\Aggregate\CustomerGroup\CustomerGroupEntity, null given, called in /mein-shop/vendor/shopware/core/System/SalesChannel/Context/SalesChannelContextFactory.php on line 225

{
    "exception": {}
}

 

CRITICAL19:16:08

request

Uncaught PHP Exception TypeError: "Argument 6 passed to Shopware\Core\System\SalesChannel\SalesChannelContext::__construct() must be an instance of Shopware\Core\Checkout\Customer\Aggregate\CustomerGroup\CustomerGroupEntity, null given, called in /mein-shop/vendor/shopware/core/System/SalesChannel/Context/SalesChannelContextFactory.php on line 225" at /mein-shop/vendor/shopware/core/System/SalesChannel/SalesChannelContext.php line 99

{
    "exception": {}
}

 

Hat hier jemand eine Idee was das sein kann?

Freue mich über jeden Tipp! Danke!

Gruß 

Mathias

Answers

  • SCOOPEXSCOOPEX MemberComments: 56 Received thanks: 23 Member since: March 16

    Hallo,

    hast Du die Verkaufskanäle korrekt zugeordnet ?

    Viele Grüße

  • DIFAOMDIFAOM MemberComments: 1 Received thanks: 0 Member since: September 1

    Hallo,

    Es gibt aktuell nur einen Verkaufskanal, dieser ist allen Produkten zugewiesen. Oder meinst du hier noch andere zuweisungen?

    Gruß

    Mathias

Sign In or Register to comment.