YodiggaYodigga MemberComments: 23 Received thanks: 0 Member since: February 2

Beim Versuch, eine Versandregel nach Gewicht zu erstellen, kann man nur ganzzahlige Werte eingeben bzw. Nachkommawerte werden auf ganze Zahlen korrigiert.

Des weiteren ist nicht ersichtlich, eher nur zu erahnen, dass die hinterlegte Maßeinheit hier wohl Kilogramm ist.

Da sich unsere Produkte aber im Bereich von wenigen bis hunderten Gramm bewegen, bringt mir ein Startgewicht von 1 Kilo nicht viel.

In früheren Versionen von SW6 waren Werte mit Nachkommastellen noch möglich.

Frage: Mach ich was falsch, ist es ein Bug oder muß ich jetzt irgendwo die Maßeinheit Gramm definieren, wenn ich sie unter den Versandeinstellungen brauche? (mit Hinzufügen bei Einstellungen - Maßeinheiten hat es nichs gebracht)

Freu mich auf Rückmeldung.

Danke und Grüße, Yodigga

Bsp-Bild siehe hier. Die eigentlichen Werte waren 0,01 bis 0,04  und 0,05 bis unendlich Halo

image

 

Comments

  • AB_SAB_S MemberComments: 157 Received thanks: 7 edited May 12 Member since: March 23

    Beim Versuch, eine Versandregel nach Gewicht zu erstellen, kann man nur ganzzahlige Werte eingeben bzw. Nachkommawerte werden auf ganze Zahlen korrigiert.

    Des weiteren ist nicht ersichtlich, eher nur zu erahnen, dass die hinterlegte Maßeinheit hier wohl Kilogramm ist.

    Da sich unsere Produkte aber im Bereich von wenigen bis hunderten Gramm bewegen, bringt mir ein Startgewicht von 1 Kilo nicht viel.

    In früheren Versionen von SW6 waren Werte mit Nachkommastellen noch möglich.

    Frage: Mach ich was falsch, ist es ein Bug oder muß ich jetzt irgendwo die Maßeinheit Gramm definieren, wenn ich sie unter den Versandeinstellungen brauche? (mit Hinzufügen bei Einstellungen - Maßeinheiten hat es nichs gebracht)

    Freu mich auf Rückmeldung.

    Danke und Grüße, Yodigga

    Bsp-Bild siehe hier. Die eigentlichen Werte waren 0,01 bis 0,04  und 0,05 bis unendlich Halo

    image

     

     Teste mal ob es mit jetzigen Stand in der V 6.2 überhaupt im Warenkorb in der Versandpreisanzeige funktioniert, bis 6.1.5 ist das nämlich nicht der Fall, da wird gar nichts mit Gewichtabhängigkeiten berechnet. Ist Schlichtweg ohne Funktion!

  • LoginfinityGruppeLoginfinityGruppe MemberComments: 2 Received thanks: 0 Member since: March 31

    @Yodigga‍ wäre super wenn du kurz Bescheid geben könntest ob es mit 6.2. funktionsfähig ist. VIelen Dank vorab. 

  • YodiggaYodigga MemberComments: 23 Received thanks: 0 Member since: February 2

    @LoginfinityGruppe

    hoffe, ich verstehe Dich richtig... In 6.2 RC1 werden schon Versandkosten nach Gewicht berechnet, allerdings erst ab 1kg. Also so, wie es im Beispielbild drüber auch angezeigt wird. Artikel im Grammbereich erfasst er nicht, da beim Definieren der Versandeinstellungen mit Gewicht jede Eingabe von 0,xxx auf 1 aufgerundet wird und somit die Gewichtsberechnung nachher im Warenkorb eben erst ab 1kg anfängt.

    Habe testweise einem Produkt ein Gewicht von 1kg gegeben und sofort wurde auch ein Preis im Warenkorb berechnet. Nur eben drunter nicht.

    Die Definition des erwarteten Werts in der DB entspricht sogar dem, was man eingeben möchte (mehrstellige Zahlen mit Komma/Punkt dazwischen - habe grade den Ausdruck dafür vergessen). Aber irgendwo passt was nicht, so dass am Ende nur Ganzzahlen bei der Definition des Von-Bis-Gewicht erlaubt zu sein scheinen (evtl im RuleBuilder).

    Vielleicht können die Entwickler hier mal nachschauen. Kann kein Riesending sein, zumal ich es in früheren Versionen auch schon korrekt einstellen konnte.

    Grüße, Y.

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 9048 Received thanks: 2698 Member since: September 2013

    Wenn ihr das Reproduzieren könnt, an besten direkt mal ein Ticket aufmachen: issues.shopware.com

  • YodiggaYodigga MemberComments: 23 Received thanks: 0 edited May 14 Member since: February 2
  • YodiggaYodigga MemberComments: 23 Received thanks: 0 Member since: February 2

    Moin.

    Ich würde das Thema gerne nochmal hochholen. Hier sollte SW besser gestern als heute nachbessern und das mit einer schnellen 6.2.1 beheben, da es mittlerweile etliche Tickets oder Foreneinträge zu dem Thema gibt, dass Versand nach Gewicht nicht definiert und produktiv genutzt werden kann.

    Spielt Gewicht beim Versand eine Rolle, kann man derzeit eigentlich nur Versandpauschalen einstellen. Für Kunden wie für Verkäufer unschön.

    Hauptprobleme:

    • Unter 1 keine Nachkommastellen zugelassen, da immer auf 1 aufgerundet wird.
    • Nachkommastellen bei Zahlen größer 1 führen zu einem Sprung beim nächsten Schritt um ein ganzes Kilogramm. Endgewicht 4,9 in Step 1 bedeutet Startgewicht von 5,9 in Step 2. Kommt eine Bestellung auf ein Gewicht dazwischen, z.B. 5,4, erhält ein Kunde die Fehlermeldung, dass Versandart für Bestellung nicht verfügbar ist.

    Danke und schönes Wochenende allerseits.

    Yodigga

     

     

     

  • AB_SAB_S MemberComments: 157 Received thanks: 7 Member since: March 23

    Moin.

    Ich würde das Thema gerne nochmal hochholen. Hier sollte SW besser gestern als heute nachbessern und das mit einer schnellen 6.2.1 beheben, da es mittlerweile etliche Tickets oder Foreneinträge zu dem Thema gibt, dass Versand nach Gewicht nicht definiert und produktiv genutzt werden kann.

    Spielt Gewicht beim Versand eine Rolle, kann man derzeit eigentlich nur Versandpauschalen einstellen. Für Kunden wie für Verkäufer unschön.

    Hauptprobleme:

    • Unter 1 keine Nachkommastellen zugelassen, da immer auf 1 aufgerundet wird.
    • Nachkommastellen bei Zahlen größer 1 führen zu einem Sprung beim nächsten Schritt um ein ganzes Kilogramm. Endgewicht 4,9 in Step 1 bedeutet Startgewicht von 5,9 in Step 2. Kommt eine Bestellung auf ein Gewicht dazwischen, z.B. 5,4, erhält ein Kunde die Fehlermeldung, dass Versandart für Bestellung nicht verfügbar ist.

    Danke und schönes Wochenende allerseits.

    Yodigga

     

     

     

    Ich wäre ja schon froh wenn´s nur mit Vollzahlen gehen würde. Ist das bei 6.2 also bereits möglich, richtig? 

  • YodiggaYodigga MemberComments: 23 Received thanks: 0 Member since: February 2

    @AB_S

    Du hast in 6.2 immer einen Sprung von einem Kilo drin. Es schließt nicht nahtlos ans vorherige Gewicht an.

    Mal schnell ein paar Stufen zum Test geschrieben, um die Gewichtssprünge zu zeigen. Geht man in der Folgezeile auf den Endwert der vorherigen, stuft er das Anfangsgewicht direkt 1 Kilo hoch.

    image

  • AB_SAB_S MemberComments: 157 Received thanks: 7 Member since: March 23

    @AB_S

    Du hast in 6.2 immer einen Sprung von einem Kilo drin. Es schließt nicht nahtlos ans vorherige Gewicht an.

    Mal schnell ein paar Stufen zum Test geschrieben, um die Gewichtssprünge zu zeigen. Geht man in der Folgezeile auf den Endwert der vorherigen, stuft er das Anfangsgewicht direkt 1 Kilo hoch.

    image

    Das ist eigenartig, bei meiner 6.1.5 version kann ich ohne weiteres in zeile 1 eingeben: 0 - 9,99 / zeile 2: 10 - XX usw. Nur rechnet leider nix, es erscheint im Warenkorb immer nur der 1. Zeilen Wert.

    Das sollte ja bei 6.2. behoben sein, das es richtig alle Zeilen berücksichtigt. Und jetzt rechnet´s aber die Nachkommafunktion ist mit Update futsch!?

  • YodiggaYodigga MemberComments: 23 Received thanks: 0 edited May 23 Member since: February 2

    @AB_S‍  Kannst Du mal ein Bild aus der 6.1.5 einstellen zum Vergleich?

    Und ging in der 6.1.5 noch Werte zwischen 0 und 1, bspw. 0,05, als Startgewicht?

  • davelanddaveland MemberComments: 38 Received thanks: 6 Member since: May 11

    Hast du es mal mit Punkt versucht? Das geht bei mir nämlich. Also nicht 0,05 sondern 0.05

  • YodiggaYodigga MemberComments: 23 Received thanks: 0 Member since: February 2

    @daveland‍  Eingeben kann ich Punktwerte wie 3.1 schon, das wird angenommen.

    Aber:

    • Werte unter 1 werden immer auf 1 aufgerundet, z.B. 0.05 = 1
    • wenn der Endwert in vorheriger Zeile z.B. 2 ist, kann ich in der Folgezeile 2.1 eingeben, wir dann direkt auf 3 aufgerundet. Gebe ich 3.1 an, ist alles ok. Muss also immer mindestens 1 kg dazwischen liegen. (letzte Zeile war die Eingabe eigentlich 4.1)

    image

  • davelanddaveland MemberComments: 38 Received thanks: 6 Member since: May 11

    Oh ja, hast Recht. Hab das nicht zu Ende gespielt...

    Frustrierend!

     

  • YodiggaYodigga MemberComments: 23 Received thanks: 0 Member since: February 2

    @Moritz Naczenski

    Hab grade nochmal die Datenbanktabelle angeschaut, in der die Versandkosten gespeichert werden.

    Als Datentyp ist hier für Start und Ende DOUBLE angegeben. Ist das korrekt?  In SW5 war der Datentyp an der Stelle noch DECIMAL.

    Mal probehalber den Typ in der DB umgestellt, hat aber auch keine Verbesserungen im Backend gebracht.

    Aber vielleicht bringt Euch der Hinweis bei der Fehlersuche was Wink

     

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 9048 Received thanks: 2698 Member since: September 2013

    Das ist nur ein Admin Problem, Ticket für die 6.2.1 ist schon angelegte 

Sign In or Register to comment.