net-Quadratnet-Quadrat MemberComments: 85 Received thanks: 18 Member since: August 2012

Hallo Zusammen,

wir haben seit dem 18.03. auf die aktuelle 6.1.4 Version umgestellt. Wir haben aber seitdem permanent das Problem, dass wir nach "kurzer Zeit" aus dem Backend fliegen. Bzw. wir sind noch im Backend, aber wenn man dann zum Beispiel auf den Produktbereich klickt, wird kein Produkt mehr angezeigt.

Wir haben seit dem Update von 6.1.3 auf 6.1.4 nur ca. 50 Produkte hinzugefügt und mehr nicht. 

Geht nur uns das so?

Viele Grüße

Benjamin

1 Answer

  • lernhartlernhart MemberComments: 3 Received thanks: 1 Member since: March 23

    Hi Benjamin, 

    der unauthorized gehört natürlich auch zu dem Problem und tritt nach dem ersten Reqeust mit dem "Request header too large" auf, da sich Deine Sitzung nicht mehr erfolgreich authentifizieren kann.

    Wir planen ein gesondertes 6.1.5 Release für Mitte der nächsten Woche, in dem ein Fix für willkürliches Ausloggen in der Administration beinhaltet ist.

    Wir haben das Problem an mehreren Stellen, die sich völlig unterschiedlich ausprägen. Daher bin ich mir sicher, dass die 6.1.5 Dein Problem beheben sollte.

     

    Viele Grüße aus Schöppingen,

    Lennart

    Quote
    Accepted Answer
    Thanked by 1wollefreak
  • Accepted Answer

Answers

  • ExeExe MemberComments: 125 Received thanks: 30 Member since: December 2014

    Ich wurde auch bei früheren Versionen zumindest lokal auch sehr oft ausgeloggt. Ob das bei 6.1.4 noch häufiger ist, kann ich noch nicht sagen. Aber grundsätzlich wäre es schön, wenn man irgendwo die Session TTL fürs Backend einstellen könnte.

  • net-Quadratnet-Quadrat MemberComments: 85 Received thanks: 18 Member since: August 2012

    Macht im Moment keinen Spaß damit zu arbeiten. :-(

  • mtrsmmtrsm MemberComments: 12 Received thanks: 0 Member since: March 15

    Hallo Benjamin!

    Wir haben seit dem Update auf 6.1.4 dasselbe Problem. Ständiges Logout, die Abstände sind relativ willkürlich.

    Ich hoffe, dafür gibt es bald eine Lösung.

  • wollefreakwollefreak MemberComments: 10 Received thanks: 1 Member since: January 31

    Hallo,

    ich habe dasselbe Problem. Es kommt immer wieder vor, dass die gewünschte (bzw. angewiesene) Aktion nicht ausgeführt wird und ich nur den Ladekreis und eine weiße Seite sehe. Logge ich mich neu ein, funktionert es sofort wieder.

    Es ist nervig und ich hoffe, das Problem wird behoben.

     

  • lernhartlernhart MemberComments: 3 Received thanks: 1 edited March 25 Member since: March 23

    Hallo Benjamin,

    ich sitze bereits an einem Fix für ein ähnliches Problem, das vielleicht auch mit dem häufigen Logout bei Dir zusammenhängt.

    Schmeißt Dein Browser in der Konsole einen "Request Header too large" o.Ä. Fehler, in dem Moment, wo Du bspw keine Produkte mehr laden kannst ? 

     

    Viele Grüße aus Schöppingen,

    Lennart

  • net-Quadratnet-Quadrat MemberComments: 85 Received thanks: 18 Member since: August 2012

    Hallo Lennart,

    ich hab dort immer folgendes Problem:

    Failed to load resource: the server responded with a status of 401 ()
    api/v1/message-queue-stats?page=1&limit=25:1
    
    Uncaught (in promise) Error: Request failed with status code 401
        at LYNF.e.exports (vendors-node.js,q15845349621360952.pagespeed.jm.YtEwiDnXKe.js:1)
        at Rn+g.e.exports (vendors-node.js,q15845349621360952.pagespeed.jm.YtEwiDnXKe.js:1)
        at XMLHttpRequest.d.onreadystatechange (vendors-node.js,q15845349621360952.pagespeed.jm.YtEwiDnXKe.js:1)
    

     

    Also ein Request Header too large bekomme ich hier nicht.

    Viele Grüße

  • lernhartlernhart MemberComments: 3 Received thanks: 1 Member since: March 23

    Hi Benjamin, 

    der unauthorized gehört natürlich auch zu dem Problem und tritt nach dem ersten Reqeust mit dem "Request header too large" auf, da sich Deine Sitzung nicht mehr erfolgreich authentifizieren kann.

    Wir planen ein gesondertes 6.1.5 Release für Mitte der nächsten Woche, in dem ein Fix für willkürliches Ausloggen in der Administration beinhaltet ist.

    Wir haben das Problem an mehreren Stellen, die sich völlig unterschiedlich ausprägen. Daher bin ich mir sicher, dass die 6.1.5 Dein Problem beheben sollte.

     

    Viele Grüße aus Schöppingen,

    Lennart

    Quote
    Accepted Answer
    Thanked by 1wollefreak
  • net-Quadratnet-Quadrat MemberComments: 85 Received thanks: 18 Member since: August 2012

    Super! Ich freu mich aufs Update. ;-) Bis dahin verliere ich dann noch ein paar Haare! ;-)

  • opalionopalion MemberComments: 79 Received thanks: 8 Member since: September 2019

    Wir haben auch das Problem mit dem ständigen Ausloggen. Ist echt nervig leider...

  • mtrsmmtrsm MemberComments: 12 Received thanks: 0 Member since: March 15

    Ich hoffe, das Update löst das Problem.

    Vielen Dank für die rasche Umsetzung!

  • mtrsmmtrsm MemberComments: 12 Received thanks: 0 Member since: March 15

    Wir haben heute das Update 6.1.5 eingespielt - das Problem tritt nach wie vor auf. In den letzten beiden Stunden hat es uns mindestens 4 mal ausgeloggt Undecided

  • net-Quadratnet-Quadrat MemberComments: 85 Received thanks: 18 Member since: August 2012

    Also bei mir ist es besser geworden. Wir fliegen nicht mehr so häufig raus.
    Gelegentlich zwar schon, aber ich glaube das liegt dann daran, dass wir wirklich inaktiv waren.

  • lernhartlernhart MemberComments: 3 Received thanks: 1 Member since: March 23

    Hallo mtrsm,

    kannst Du etwas genauer sein bitte ? :) 

    Ist der Logout nach wie vor "willkürlich" oder passiert das nur bei bestimmten Aktionen in der Administration ?

    Bist Du mit mehreren Sitzungen über den gleichen Account in der Administration gleichzeitig angemeldet ? 

    Arbeitest Du mit dem gleichen Account über mehrere Systeme hinweg ? 

    Viele Grüße aus Schöppingen,

    Lennart

    PS: net-Quadrat, der Logout sollte eigentlich gar nicht mehr auftreten, auch nicht gelegentlich ;)
    Vielleicht kannst Du mir dazu auch weitere Informationen geben ?

  • net-Quadratnet-Quadrat MemberComments: 85 Received thanks: 18 Member since: August 2012

    Also ich "fliege" nach einer halben / dreiviertel Stunde "nichts tun" raus. ;-)

    Also ich hab das damit verbunden, dass irgendwann bestimmt einfach nen Timeout kommt.
    Während des Arbeitens fliege ich aber nicht mehr raus.

  • lababalababa MemberComments: 2 Received thanks: 0 Member since: October 2017

    Hallo,

    für einen Kundenprojekt habe ich mich für Shopware 6 entschieden. Leider musste ich feststellen, dass dieses Problem selbst mit der Version 6.2.3 noch besteht - obwohl man aktiv im Backend arbeitet wird man sporadisch ausgeloggt. Das Problem ist auch nicht reproduzierbar ich werde es weiterhin beobachten und ggf. die Fehlermeldung hier anhängen.

  • lababalababa MemberComments: 2 Received thanks: 0 edited October 8 Member since: October 2017

    ok ging wohl schneller als gedacht:

    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (message-queue-stats, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (message-queue-stats, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (token, line 0)
    [Error] Unhandled Promise Rejection: TypeError: undefined is not an object (evaluating 't.response')
        (anonyme Funktion) (commons.js:1:169639)
        promiseReactionJob
    [Error] Unhandled Promise Rejection: Error: Request failed with status code 401
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (token, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (message-queue-stats, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (message-queue-stats, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (message-queue-stats, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (token, line 0)
    [Error] Unhandled Promise Rejection: TypeError: undefined is not an object (evaluating 't.response')
        (anonyme Funktion) (commons.js:1:169639)
        promiseReactionJob
    [Error] Unhandled Promise Rejection: Error: Request failed with status code 401
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (snippet-set, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (token, line 0)
    [Error] Unhandled Promise Rejection: TypeError: undefined is not an object (evaluating 't.response')
        (anonyme Funktion) (commons.js:1:169639)
        promiseReactionJob
    [Error] Unhandled Promise Rejection: Error: Request failed with status code 401
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (snippet-set, line 0)
    [Error] Unhandled Promise Rejection: TypeError: undefined is not an object (evaluating 't.response')
        (anonyme Funktion) (commons.js:1:169639)
        promiseReactionJob
    [Error] Unhandled Promise Rejection: Error: Request failed with status code 401
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (run, line 0)
    [Error] Failed to load resource: the server responded with a status of 401 (Unauthorized) (token, line 0)
    [Error] The source list for Content Security Policy directive 'script-src' contains an invalid source: ''strict-dynamic''. It will be ignored.
    > Ausgewähltes Element
    [Error] Not allowed to load local resource: blob://nullhttp//domain.de/e2ca1dcd29f88ab024a3.worker.js.map
    [Error] Not allowed to request resource
    [Error] Cannot load blob://nullhttp//domain.de/e2ca1dcd29f88ab024a3.worker.js.map due to access control checks.

  • AB_SAB_S MemberComments: 357 Received thanks: 38 Member since: March 23

    Hi Benjamin, 

    der unauthorized gehört natürlich auch zu dem Problem und tritt nach dem ersten Reqeust mit dem "Request header too large" auf, da sich Deine Sitzung nicht mehr erfolgreich authentifizieren kann.

    Wir planen ein gesondertes 6.1.5 Release für Mitte der nächsten Woche, in dem ein Fix für willkürliches Ausloggen in der Administration beinhaltet ist.

    Wir haben das Problem an mehreren Stellen, die sich völlig unterschiedlich ausprägen. Daher bin ich mir sicher, dass die 6.1.5 Dein Problem beheben sollte.

     

    Viele Grüße aus Schöppingen,

    Lennart

    Nun, wir haben jetzt 7 Monate später und zig SW Versionen / Updates sind dazu gekommen, was aber offensichtlich nichts gebracht hat. Bin bei 6.3.2 und werden nach aktuellem Update permanent aus dem BE rausgeworfen. Egal an welcher Stelle und wobei. Zu "guter Letzt" kam dann die Gnade und mir wurde die zigfache Einloggerei erspart, weil gar kein Backend mehr vorhanden!

    Es scheint so, dass das was womöglich zwischendurch behoben wurden jederzeit als BUG wieder reinfabriziert wird. Sei es im Core oder per Plug. Und auf diese lässt sich nur schwer verzichten, wenn es ein halbwegs professioneller Shop sein soll, sonst kann man auch gleich zu den bekannten Instantshops to go wechseln.

  • mtrsmmtrsm MemberComments: 12 Received thanks: 0 Member since: March 15

    Bei uns kommt es zum Glück nur mehr sehr selten vor. Aber zu 100% weg ist das Problem auch nicht...

  • Werner_FriedrichsWerner_Friedrichs MemberComments: 6 Received thanks: 0 Member since: October 7

    Hi Benjamin, 

    der unauthorized gehört natürlich auch zu dem Problem und tritt nach dem ersten Reqeust mit dem "Request header too large" auf, da sich Deine Sitzung nicht mehr erfolgreich authentifizieren kann.

    Wir planen ein gesondertes 6.1.5 Release für Mitte der nächsten Woche, in dem ein Fix für willkürliches Ausloggen in der Administration beinhaltet ist.

    Wir haben das Problem an mehreren Stellen, die sich völlig unterschiedlich ausprägen. Daher bin ich mir sicher, dass die 6.1.5 Dein Problem beheben sollte.

     

    Viele Grüße aus Schöppingen,

    Lennart

    Ich denke mal das Update hat nichts gebracht, oder das Problem ist mit der 6.3 Version wieder zurück.

    Also die 6er Version nervt und kränkelt an allen Ecken auch die Erlebniswelten sind für mich kein wirkliches Erlebnis, mal schauen wohin die Reise geht.

     

  • realconvisrealconvis MemberComments: 13 Received thanks: 1 edited November 12 Member since: February 7

    Möchte das Thema auch nochmal aufgreifen.

    Bei uns ist es in der aktuellen 6.3.3.1 Version auch so, dass man immer wieder sporadisch ausgeloggt wird.

    Wann wird das mal gefixt werden?

    Oder hat da jemand bereits ne Lösung?

  • net-Quadratnet-Quadrat MemberComments: 85 Received thanks: 18 Member since: August 2012

    Wir haben das momentan auch wieder. Auch in der 6.3.3.1.
    Wir können das Verhalten aber noch nicht reproduzieren. Das passiert während man in den Artikeln arbeitet.

  • annacontaannaconta MemberComments: 511 Received thanks: 67 Member since: February 13

    ich werde permanent seit monaten während des arbeitens rausgeworfen. laut timme werden auch keine error logs ausgeworfen. mein ticket dazu: https://issues.shopware.com/issues/NEXT-10663 bitte voten

  • DoneDone MemberComments: 7 Received thanks: 2 Member since: September 7

    Habe das selbe Problem... schön vor allem wenn man gerade ein großes CSV Importiert und dieser deshalb abbricht.

  • AB_SAB_S MemberComments: 357 Received thanks: 38 Member since: March 23

    Möchte das Thema auch nochmal aufgreifen.

    Bei uns ist es in der aktuellen 6.3.3.1 Version auch so, dass man immer wieder sporadisch ausgeloggt wird.

    Wann wird das mal gefixt werden?

    Oder hat da jemand bereits ne Lösung?

    Kann ich bei mir auch bestätigen 

Sign In or Register to comment.