ShopwareNoobyShopwareNooby MemberComments: 10 Received thanks: 0 Member since: January 2020

Hallo zusammen, 

ich entwickle mein ShopwareTheme lokal mit vagrant, seid kurzem kann ich mich jedoch nicht einloggen, ich bekomme die Fehlermeldung status undefined. 

Wenn ich die folgende URL https://192.168.33.10/api/oauth/token eingebe bekomme ich die Fehlermeldung:

{"errors":[{"code":"0","status":"405","title":"Method Not Allowed","detail":"No route found for \u0022GET \/api\/oauth\/token\u0022: Method Not Allowed (Allow: POST)","meta":{"trace":[{"file":"\/home\/vagrant\/shopware-dev\/vendor\/symfony\/event-dispatcher\/Debug\/WrappedListener.php","line":126,"function":"onKernelRequest", ...

ausgegeben.

Ich wäre sehr dankbar wenn mir jemand helfen könnte.

Grüße 

Vanessa :)

Answers

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 9918 Received thanks: 3008 Member since: September 2013

    Das ist allerdings keine Fehlermeldung die uns weiterbringt.

    Schau doch mal in die Konsole ob es da Fehler gibt und auch im Netzwerktab wenn du dich normal einloggst. Die Fehlermneldung entsteht ja nur, weil du die URL per GET im Browser aufrufst.

    Thanked by 1ShopwareNooby
  • ShopwareNoobyShopwareNooby MemberComments: 10 Received thanks: 0 Member since: January 2020

    Hallo Moritz,

    danke für die schnelle Antwort. 

    In der Konsole wird mir kein Fehler ausgegeben, bzw. werde ich dort nicht nach Login Daten gefragt und unter dem Netzwerktab wird mir das angezeigt:

    image

    Gibt es eine Möglichkeit mit die URL per POST Methode aufzurufen?

    Grüße 

    Vanessa :)

  • FloC3FloC3 MemberComments: 1036 Received thanks: 64 Member since: October 2017

    hab hier das selbe Problem. In einem Shop funktioniert es, im anderen kommt genau die Fehlermeldung oben.

    Selbes Plugin, welches ein Command enthält um etwas über die API zu machen.

    Woran kann das liegen?

Sign In or Register to comment.