lanaiilanaii MemberComments: 7 Received thanks: 0 Member since: September 2016

Hallo,

ich weiß es gibt schon einige Foren Einträge diesbezüglich aber keines konnte mir helfen.

 

Und zwar geht es darum, das Ich versuche Shopware 6.1 mit dem Mailer zu konfigurieren, doch leider lässt sich dieser trotz korrekter SMTP Einstellungen von Office365 nicht dazu bringen, E-Mails bei registrierungen, Bestellungen, etc. zu versenden.

 

Wenn Ich Lokaler E-Mail Agent aktiviere, werden E-Mails versendet, aber kommen niemals an.

 

  • Gehostet/Bezogen wurde Office365 bei 1&1.
  • E-Mail Vorlagen wurden dem Saleschannel zugewiesen
  • Genutzt wird aktuell Shopware6.1

Ich hoffe jemand hat hierfür einen Rat/Erfahrungen mit Office365 und Shopware

Answers

  • net-Quadratnet-Quadrat MemberComments: 71 Received thanks: 17 Member since: August 2012

    Du kannst die Domain smtp.office365.com nicht dafür nutzen. Bzw. Du musst in den Administrationsbereich vom Exchange in Office 365 dafür evtl. die IP Adresse vom Server freigeben, auf dem dein Shop läuft. Ansonsten blockt Microsoft die E-Mails.

    Am einfachsten kannst Du dir evtl. über deinen Microsoft Office Tenant Domain-com.mail.protection.outlook.com den Zugang verschaffen. Aber auch hier musst du wahrscheinlich in den Exchange Einstellungen sagen, dass du von dort aus Mails verschicken kannst.

     

    Viele Grüße

    Benjamin

  • lanaiilanaii MemberComments: 7 Received thanks: 0 Member since: September 2016

    Hallo Benjamin,

     

    habe das gerade über sender.office.com überprüft, und die IP ist nicht gesperrt.

    vorallem wir nutzen dieses Postfach ebenfalls über unser derzeitiges xtCommerce, zum versenden der Bestellungen.

     

    da muss wo anders das Problem liegen.

  • lanaiilanaii MemberComments: 7 Received thanks: 0 Member since: September 2016

    Hat hier noch jemand einen Rat, da man im Forum viel Lust und ja einige das Problem haben.

  • lanaiilanaii MemberComments: 7 Received thanks: 0 Member since: September 2016

    Anbei kurzes Feedback, von IONOS gibt es keine tenant Rechte, somit nicht einstellbar.

    Ich habe heute einiges versucht, und meine .env angepasst

    MAILER_URL=smtp://smtp.office.de:587?encryption=tls&auth_mode=login&username={USERNAME}&password=[PASSWORD}

    Bekomme aber immer wieder Fehlermeldung, wie

    Exception occurred while flushing email queue: Failed to authenticate on SMTP server with username "xxx" using 1 possible authenticators. Authenticator LOGIN returned Expected response code 235 but got code "535", with message "535 5.7.3 Authentication unsuccessful [FRAPR01CA0066.DEUPRD01.PROD.OUTLOOK.DE] ". [] []

    oder

    app.ERROR: Exception occurred while flushing email queue: Connection could not be established with host smtp.office.de [ #0] [] []

     

    Anschließend mal mit unseren alten backup mails getestet (hosted bei 1und1), und siehe da Testversand funktioniert, es kommt zwar keine Bestellbestätigung an (trotz zuweisung) aber ist schon mal ein anhaltspunkt.

    Vielleicht nutzt ja noch jemand Office365 Business hier, und hat einen Rat dazu.

  • net-Quadratnet-Quadrat MemberComments: 71 Received thanks: 17 Member since: August 2012

    Ich bin immer noch der Meinung, dass Du deinem Exchange sagen musst, dass der von extern Mails annehmen darf.
    Hast Du im Exchange Admin Center unter Nachrichtenfluss einmal unter Connectors einen Connector angelegt mit der IP Adresse von deinem Server der die Mails verschicken möchte?

  • lanaiilanaii MemberComments: 7 Received thanks: 0 Member since: September 2016

    Die Connectors sind leer. Welche IP Adresse meinst du genau??

  • net-Quadratnet-Quadrat MemberComments: 71 Received thanks: 17 Member since: August 2012

    Du legst einen Connector an und hinterlegst dort die IP Adresse des Servers (auf dem deine Shopwareinstallation läuft).

  • lanaiilanaii MemberComments: 7 Received thanks: 0 Member since: September 2016

    Ok Connector ist angelegt, aber leider bekomme Ich keine MX Adresse, um diese als SMTP zu nutzen :(

    Vlt. hilft es das wir Office365 nicht direkt von Microsoft bezogen haben, sondern über 1&1 vor ca. 2 jahren.

     

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 8570 Received thanks: 2538 Member since: September 2013

    Also ich hatte mir das ja auch angeschaut und bin auf folgenden Beitrag von MS gestoßen: https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_winother/client-was-not-authenticated-to-send-anonymous/d405bcb0-f40c-42fa-b1b2-477597100123

    Und lt. dem Support dort,  braucht man einen Tenant, damit auch eine Application Mails versenden kann.

Sign In or Register to comment.