ShopwareianerShopwareianer MemberComments: 3560 Received thanks: 629 Member since: November 2013 edited September 12

In meiner base.scss in einem Theme Plugin muss ich ja etliche core scss Dateien einbinden, damit auch custom Variablen usw. übernommen werden.

Daher binde ich unter anderem auch die vendor bootstrap ein:

@import './../../../../../../../platform/src/Storefront/Resources/src/style/vendor/bootstrap';

Im hot-reload Modus funktioniert alles ohne Probleme - Sobald man das Theme allerdings mit dem :build Modus kompilieren will, bekomme ich den Fehler:

In Parser.php line 133:
                              
  Unopened { [line no: 7708]  

Die storefront wird aufgrund dieses Fehler im :build Modus nicht kompiliert. Dieser Fehler resultiert aus der bootstrap.scss Die /vendor/bootstrap referenziert aus dem core theme wiederum auf

@import '~vendor/bootstrap/scss/bootstrap';

Hier scheint es dann irgendwo zu hacken. Hat jemand dasselbe Problem? Ist der Fehler bekannt? Mache ich es falsch?

Comments

  • MoorleicheMoorleiche MemberComments: 61 Received thanks: 7 Member since: August 3

    Ich Habe das Style des Storefronts einfach komplett aus meiner theme.json raus gehauen und die vendor ordner in mein Theme-Plugin kopiert... zu erst probiert zu fruckeln und die Storefront Styles zu überschreiben, aber nach ca 23489 Wutausbrüchen mich entschieden es clean zu machen :D

    Thanked by 1Shopwareianer
  • ShopwareianerShopwareianer MemberComments: 3560 Received thanks: 629 Member since: November 2013

    Ja das ist totaler Murx mit den ganzen Imports ... :D

    Ich frage mich was da tatsächlich der richtige Weg ist bei einem Theme Plugin ..

    Danke dir, dann werde ich das wohl auch mal so machen :P

  • mdswmdsw MemberComments: 137 Received thanks: 5 Member since: June 2017

    @Moritz Naczenski

    Kannst Du hier mal in Erfahrung bringen wie das gedacht ist? Mit Shopware 6 soll das Theming ja prinzipiell einfacher werden...
    So scheint es aber noch nicht richtig zu funktionieren.

    Gibt es hierzu bald ein How To oder so? Halo

  • thomthom MemberComments: 48 Received thanks: 8 Member since: April 2014

    hey, wie in diesem Beitrag schon mal erwähnt ist die Tilde in dem Shopware Core das Problem:
    https://forum.shopware.com/discussion/comment/256926/#Comment_256926

    wenn es ohne Tilde importiert wird geht es.

    Somit wäre es shopware-seitig schön wenn die das ohne Tilde importieren.
    Evtl. mal ein Ticket erstellen?

  • imisesimises MemberComments: 6 Received thanks: 0 Member since: July 31

    Das Problem ist eher, das der HOT Modus noch nicht richtig läuft. So weit ich das raus finden konnte.

    HOT Modus:
    - Variablen / Mixins werden nicht durch geschliffen von Bootstrap / SW
    - Als Workaround kann man die ganzen Dinge importieren

    WATCH bzw. BUILD Modus:
    - Variablen / Mixins werden durchgeschliffen
    - Wenn man die SW und Bootstrap Files für den HOT Modus importiert hat, dann lässt sich der BUILD-Modus nicht nutzen...

    Ich habe es nun so gemacht, das bei einer Änderung einer SCSS Datei in meinem Themen per Gulp ein Build angestoßen wird.
    Spaß macht das bearbeiten von CSS aber damit auch nicht, da jeder Build 10 Sekunden dauert.

Sign In or Register to comment.