charlotteeecharlotteee MemberComments: 5 Received thanks: 0 Member since: July 2019 edited August 2019

Hi there,

I recently tried many times to update my code by doing git rebase. But I kept getting the following issue.

	Fatal error: Uncaught Symfony\Component\Debug\Exception\ClassNotFoundException: Attempted to load class "Elasticsearch" from namespace "Shopware\Elasticsearch".
	Did you forget a "use" statement for another namespace? in /Users/yichengzhang/Documents/mywork/bestwatershop/shopware/development/platform/src/Core/Kernel.php:85
	Stack trace:
	#0 shopware/development/vendor/symfony/http-kernel/Kernel.php(424): Shopware\Core\Kernel->registerBundles()
	#1 shopware/development/platform/src/Core/Kernel.php(119): Symfony\Component\HttpKernel\Kernel->initializeBundles()
	#2 shopware/development/vendor/symfony/framework-bundle/Console/Application.php(159): Shopware\Core\Kernel->boot()
	#3 shopware/development/vendor/symfony/framework-bundle/Console/Application.php(65): Symfony\Bundle\FrameworkBundle\Console\Application->registerCommands()
	# in shopware/development/platform/src/Core/Kernel.php on line 8

Also, there seems to be a bug here

 $connection->getConfiguration()->setSQLLogger(
        new \Shopware\Core\Profiling\Doctrine\DebugStack()
    );

I am a front-end developer and I only focus on UI development. I would like to simply develop a UI template with css styles. It will be very useful to have some tutorials on how to create a new template with your own images/styles/JS animations and apply it.

Thank you in advance.

Answers

  • ShyimShyim MemberComments: 1234 Received thanks: 496 Member since: May 2015

    Hey,

    did you tried git pull in the main folder with an followed composer update?

  • charlotteeecharlotteee MemberComments: 5 Received thanks: 0 Member since: July 2019

    Hey,

    did you tried git pull in the main folder with an followed composer update?

     

    I think I'm up-to-date

     

  • n8lauschern8lauscher MemberComments: 191 Received thanks: 7 edited September 2019 Member since: October 2015

    @shiym 

    ja klar - das composer Update - hatte ich auch vergessen

Sign In or Register to comment.