hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 Member since: August 12 edited August 12

Hallo Community,

ich habe heute (leider) versucht das Update duchzuführen. Ich habe vorab die Plugins aktualisiert und den Lizenzmanager deinstalliert. Dann auf PHP7.2 umgestellt (Hoster all-inkl)

Dann das Update gestartet, lief auch durch. Danach im Front- und Backend:

Diese Seite funktioniert nicht

www.hologramm-sticker.de kann diese Anfrage momentan nicht verarbeiten.

HTTP ERROR 500

Ein paar Sachen habe ich nach Befragung von Google schon versucht:

Rechte, alle Ordner 755, Dateien auf 644 -> Fehler bleibt
In der .htaccess RewriteBase /shopware/ eingefügt -> ändert nur die Fehlermeldung, shop geht dennoch nicht

Leider finde ich auch keine Log-Files die mir weiterhelfen könnten. Bei all-inkl sind die wohl nicht aktiv. Habe versucht die über die .htaccess einzuschalten:

php_flag log_errors on<br /> php_value error_log "/www/htdocs/wxxxxx/hologramm-sticker.de/shop/logs/error.log"<br /> war aber nicht erfolgreich, der Ordner "logs" bleibt leer und ich finde keine Logfiles.

Kann mir jemand helfen die Log-Files zu finden oder hat jemand einen anderen Tip was ich gegen den Error 500 versuchen kann?

Vieeeelen Dank!
Michael

Comments

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7594 Received thanks: 2239 Member since: September 2013
    Thanked by 1hologrammsticker
  • hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 edited August 13 Member since: August 12

    Super, danke. Das hilft schonmal. Jetzt bekomme ich eine Fehlermeldung die wenn ich das richtig deute auf das Paypal-Plugin hinweist.
    Kann ich das irgendwie händisch deaktivieren / deinstallieren (vielleicht über die Datenbank)? Hier die Fehlermeldung:

    Fatal error: Uncaught Error: Undefined class constant 'VERSION' in /www/htdocs/w0150595/hologramm-sticker.de/shop/engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Bootstrap.php:146 Stack trace: #0 /www/htdocs/w0150595/hologramm-sticker.de/shop/engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Bootstrap.php(228): Shopware_Plugins_Frontend_SwagPaymentPaypal_Bootstrap->get('template') #1 /www/htdocs/w0150595/hologramm-sticker.de/shop/engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Subscriber/BackendIndex.php(58): Shopware_Plugins_Frontend_SwagPaymentPaypal_Bootstrap->registerMyTemplateDir() #2 /www/htdocs/w0150595/hologramm-sticker.de/shop/engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Bootstrap.php(280): Shopware\SwagPaymentPaypal\Subscriber\BackendIndex->onPostDispatchBackendIndex(Object(Enlight_Controller_ActionEventArgs)) #3 /www/htdocs/w0150595/hologramm-sticker.de/shop/engine/Library/Enlight/Event/Handler/Plugin.php(145): Shopware_Plugins_Frontend_SwagPaymentPaypal_Boot in /www/htdocs/w0150595/hologramm-sticker.de/shop/engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/Bootstrap.php on line 146

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7594 Received thanks: 2239 edited August 13 Member since: September 2013

    Das Plugin ist noch nicht als kompatibel markiert. Ich denke daher knallt das.

    Versuche mal die Teile 146 der Bootstrap.php in /www/htdocs/w0150595/hologramm-sticker.de/shop/engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal/ zu ändern. 

    if (version_compare(Shopware::VERSION, '4.2.0', '<') && Shopware::VERSION !== '___VERSION___') {

    Ändern in

    if (version_compare(Shopware()->Container()->get('config')->get('version'), '4.2.0', '<') && Shopware()->Container()->get('config')->get('version') !== '___VERSION___') {

    Danach sollte das wieder funktionieren.

    Alternativ kannst du das Plugin natürlich über die s_core_plugins deaktivieren.

    Thanked by 1hologrammsticker
  • hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 Member since: August 12

    Super! Läuft wieder. Muss ich da jetzt noch was nacharbeiten oder kann das so bleiben?

    Das Paypal-Plugin hatte ich ja eigentlich vor dem Update aktualisiert.

     

    Danke!!!

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7594 Received thanks: 2239 Member since: September 2013

    Es wird nich ein Update für 5.6 des Plugins in den nächsten Wochen geben.

    Am betsen machst du einige Tests, wenn das alles so läuft, kannst du es natürlich weiter benutzen.

    Thanked by 1hologrammsticker
  • hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 Member since: August 12

    Alles klar.

    Vielen Dank für die schnelle und kompetente Hilfe!

  • hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 edited August 13 Member since: August 12

    Hallo,

    ich muss das jetzt doch nochmal hoch holen.

    Paypal lief nicht, habe daher die Zahlungsweise erstmal deaktiviert.

    Jetzt wollte ich im Plug-in-Manager mal nachsehen ob ich da was tun kann. Der läuft aber nicht. Ich bekomme im Backend wenn ich den Pluginmanager aufrufe folgende Fehlermeldung:

    Error

    The file /www/htdocs/wxxxxxx/hologramm-sticker.de/shop/engine/Shopware/Plugins/Community/Frontend/IdeeAlertBoxGlobal/Bootstrap.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1.

    File:Unknown

     

    Ich bekomme dann keine Installierten Plugins angezeigt und kann somit ggf. auch keine updates machen.

    Eine Idee was ich da tun kann bzw. wo das Problem liegt?

    Vielen Dank!
    Michael

  • StefanWirtzStefanWirtz MemberComments: 4 Received thanks: 0 Member since: August 2018

    Hi,

    die Meldung besagt, dass das Plugin IdeeAlertBoxGlobal per ionCube verschlüsselt wird.
    DIe Versschlüsselung wird jedoch ab PHP 7.1 und neuer nicht mehr unterstützt.
    Damit der Pluginmanager wieder normal geöffnet werden kann, sollte in der Datenbank in der Tabelle s_core_plugins der Eintrag in der Spalte active von 1 auf 0 geändert werden und zusätzlich das gesamte Plugin-Verzeichnis vom Webserver gelöscht werden.
    Anschließend sollte der Plugin-Manager wieder wie gewohnt geöffnet werden können.
    (Ggfs. ist es dann noch erforderlich, den Eintrag für das Plugin im Plugin-Manager manuell zu entfernen).

    Vor einem Update sollte jedoch generell immer geprüft werden, ob die vorhandenen Plugins kompatibel sind, um ein solches Verhalten zu verhindern.

  • hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 Member since: August 12

    Hallo,

    danke für die Antwort. Ja das wird mir so schnell nicht wieder passieren.

    Bevor ich Fehler mache frage ich jetzt lieber noch genau nach.

    In der Tabelle s_core_plugins sind mehrere Datensätze, soll da bei allen "active" auf 0 gesetzt werden oder nur bei einem bestimmten Eintrag?
    Welches Verzeichnis genau ist das Plugin-Verzeichnis? (shop/engine/Shopware/Plugins)?

    Wenn ich das lösche dann sind ja sicher alle plugins weg!?

    Danke für die Hilfe!

     

  • R4MR4M MemberComments: 1692 Received thanks: 267 Member since: April 2014

    Sollte das besagte Plugin gelöscht werden, dann muss es auch in der Datenbank gelöscht werden. Danach den kompletten Cache leeren. Aber bitte nicht das Plugin-Verzeichnis löschen.

  • StefanWirtzStefanWirtz MemberComments: 4 Received thanks: 0 Member since: August 2018

    In der Datenbanktabelle ist für jedes im Shop vorhandene Plugin ein EIntrag vorhanden, hier nur für das entsprechende Plugin den activ-Eintrag anpassen.
    Der genaue Pfad auf dem Webserver ist in der Meldung enthalten "/engine/Shopware/Plugins/Community/Frontend/IdeeAlertBoxGlobal", also im Pluginverzeichnisses nur das Unterverzeichnis für das eine Plugin löschen, sonst sind in der Tat alle Plugins weg.

  • hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 Member since: August 12

    Hallo,

    danke nochmal für die Hilfe. Ich lasse jetzt über den Provider ein komplettes Backup rücksichern, das ist mir zu viel Gefrickel und ich weiß ja auch nicht genau wann dann die neue Version vom Paypal-Plugin kommt.

    mfG
    Michael

  • R4MR4M MemberComments: 1692 Received thanks: 267 Member since: April 2014

    Ich lasse jetzt über den Provider ein komplettes Backup rücksichern

    Vor dem Update selber kein Backup gemacht?

     

    https://docs.shopware.com/de/shopware-5-de/update-guides/shopware-aktualisieren-updaten

    Backups erstellen

    Bevor Du Shopware updatest, erstelle in jedem Fall ein Backup, nur so kannst Du bei Problemen einfach wieder den Betrieb aufnehmen!

    Plugin Kompatibilität - WICHTIG

    Stelle vor dem Update sicher, dass alle Deine installierten Plugins aktuell und kompatibel sind und lösche ggf. inkompatible Plugins, bevor Du updatest, da es sonst beim Update zu Problemen kommen kann und Du ein Backup einspielen musst. Es dürfen keine inkompatiblen Plugins im Plugin-Manager auftauchen! Egal ob aktiv oder nicht.

    Ob Deine Plugins kompatibel sind, siehst Du in unserem Store, über die Überprüfung durch den Auto-Updater im Backend oder über den Shopware-Account unter Lizenzen prüfen.

  • hologrammstickerhologrammsticker MemberComments: 7 Received thanks: 0 Member since: August 12

    Ja, hatte leider kein (aktuelles) Backup. Ging über den Provider aber alles problemlos innerhalb von Minuten.

    Ich schiebe das Update jetzt erstmal auf und warte ab bis das Paypal plugin überarbeitet ist.

    Nochmal danke an alle für die Unterstützung.

  • piccolinapiccolina MemberComments: 20 Received thanks: 0 Member since: August 2014

    Mal eine Verstäntnisfrage: es gibt ja 2 PayPal PlugIn's:

    - PayPal Plus
    - PayPal Express

    Von welchem dieser beiden ist hier die Rede?

     

  • drakondrakon MemberComments: 930 Received thanks: 263 Member since: February 2014

    Nein, eigentlich gibt es 3:

     

    PaypalPlus funktioniert nur zusammen mit PaypalExpress. Das dritte, neue ist das Paypal (unified).

    Thanked by 1piccolina
  • piccolinapiccolina MemberComments: 20 Received thanks: 0 Member since: August 2014

    das bedeutet, dass ich PayPal Express und PayPal Plus löschen muss?

    Sien das verschlüßelte Module?

     

  • R4MR4M MemberComments: 1692 Received thanks: 267 Member since: April 2014

    PS: Die neue Version beinhaltet PayPal Plus und PayPal Express-Button

Sign In or Register to comment.