ThalionThalion MitgliedKommentare: 6 Danke erhalten: 0 Mitglied seit: Mai 2018

Hallo

seit dem Update auf die neueste Shopware Version und nach Installation des aktuellen Paypal Plus Plugins erscheint o.g. Fehlermeldung im Checkout bei Auswahl der Zahlungsarten.

Das alte Modul wurde richtig deinstalliert, es wurden alle Lösungsansätzte überprüft. Es gibt auch keinerlei Fehlermeldung hinsichtlich Webhook und API. Alles erscheint als "Erfolgreich" im Backend. Das neue Plugin wurde auch richtig konfiguriert:

1. Plugin ist aktiviert
2. Client ID und Secret ist richtig eingetragen (und wird auch als erfolgreich "quittiert")
3. Paypal ist Standardzahlungsart
4. Es gibt keine doppelten Paypal Ordner im Plugin Verzeichnis (Wie in einem anderen Lösungsansatz beschrieben)
5. Es gibt keine PHP Dateien ohne Namen (Wie in einem anderen Lösungsansatz beschrieben)
6: Das alte Plugin erfolgreich und komplett deinstalliert

 

Hat jemand eine Idee woran es noch liegen könnte?

 

Danke und viele Grüße

«1

Antworten

  • ThalionThalion MitgliedKommentare: 6 Danke erhalten: 0 Mitglied seit: Mai 2018

    Das sagt die log datei: [2019-02-11 10:08:27] plugin.ERROR: PayPal: Could not register webhooks due to a communication failure {"message":"Client error response [url] https://api.paypal.com/v1/notifications/webhooks [status code] 400 [reason phrase] Bad Request","payload":"{\"name\":\"WEBHOOK_URL_ALREADY_EXISTS\",\"message\":\"Webhook URL already exists\",\"debug_id\":\"36b5836ca53b\",\"information_link\":\"https://developer.paypal.com/docs/api/webhooks/#errors\",\"details\":[],\"links\":[]}"} {"uid":"4ea3524"}

  • taauchertaaucher MitgliedKommentare: 1325 Danke erhalten: 135 Mitglied seit: Oktober 2010

    Es gibt hier wohl einige mit diesem Problem, ich warte seit Donnerstag auf eine Lösung seitens Shopware.

    Danke von 1Thalion
  • ThalionThalion MitgliedKommentare: 6 Danke erhalten: 0 Mitglied seit: Mai 2018

    Oha, das war mir nicht bewusst. Dann warten wir mal ab. 

  • valivali MitgliedKommentare: 26 Danke erhalten: 5 Mitglied seit: Mai 2018

    Ich schließ mich der Diskussion mal an. Hatten bis gestern noch das PayPal Plugin in Version 2.0.3 im Einsatz (mit PayPal Plus). Heute hab ich es mal auf die neuste Version geupdatet. Nun sehe ich das die Zahlungsmöglichkeiten für PayPal Plus gar nicht mehr vorhanden sind, obwohl weiterhin aktiviert... Nur noch das normale PayPal. Gestern kamen noch Käufe auf Rechnung rein...

    Heißt das nun, dass PayPal gerade ein allgemeines Problem mit Plus hat und alle von betroffen sind, oder liegt es tatsächlich nun an der neusten Version des Plugins?

    Cache geleert, PayPal Plus deaktiviert/wieder aktiviert...alles schon gemacht. Hat nicht geholfen

  • ThalionThalion MitgliedKommentare: 6 Danke erhalten: 0 Mitglied seit: Mai 2018
    Schau am besten mal in den Log Files ob es dort ähnlich aussieht wie bei mir.

    Ich schließ mich der Diskussion mal an. Hatten bis gestern noch das PayPal Plugin in Version 2.0.3 im Einsatz (mit PayPal Plus). Heute hab ich es mal auf die neuste Version geupdatet. Nun sehe ich das die Zahlungsmöglichkeiten für PayPal Plus gar nicht mehr vorhanden sind, obwohl weiterhin aktiviert... Nur noch das normale PayPal. Gestern kamen noch Käufe auf Rechnung rein...

    Heißt das nun, dass PayPal gerade ein allgemeines Problem mit Plus hat und alle von betroffen sind, oder liegt es tatsächlich nun an der neusten Version des Plugins?

    Cache geleert, PayPal Plus deaktiviert/wieder aktiviert...alles schon gemacht. Hat nicht geholfen

  • valivali MitgliedKommentare: 26 Danke erhalten: 5 Mitglied seit: Mai 2018

    Soweit ich weiß ensteht die Meldung im Log immer, wenn der Webhook bereits eingetragen ist und man in den Einstellungen etwas speichert.

    Hab eben im Testshop die neuste Version von PayPal aufgespielt und siehe da... PayPal Plus Zahlungsarten sind ebenfalls verschwunden. Wieder auf die alte 2.0.3 und es geht wieder. Es muss scheinbar ein Problem mit der neusten Version von PayPal geben

    Live, als auch Testshop sind in 5.5.4

  • sonicsonic MitgliedKommentare: 1944 Danke erhalten: 536 Mitglied seit: Januar 2014

    Im aktuellen Update hat es auch eine Änderung am JS gegeben, darum reicht "Cache leeren" nicht, da muss auch zwingend das Theme neu compiliert werden.

  • valivali MitgliedKommentare: 26 Danke erhalten: 5 Mitglied seit: Mai 2018

    Hallo sonic,

    hatte ich natürlich auch gemacht, dennoch nichts gebracht.

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 6472 Danke erhalten: 1923 bearbeitet 11. Februar Mitglied seit: September 2013

    Also ein allgemeines Problem kann ich aktuell nicht reproduzieren mit PaypalUnified 2-1-1. 

    Die Payment-Wall wird wie gewohnt angezeigt:

    image

    und auch der Checkout leitet auf die Plus-Zahlungsart weiter:

    image

     

    Der Iframe kommt ja direkt von Paypal, es kann natürlich sein, dass es dort aktuell Probleme gibt. Die Implementierung scheint generell zu funktionieren im Sandbox-Modus. Der Inhalt des Iframes selbst wird vom Plugin nicht gesteuert.

    Die Meldung mit dem Webhooks ist egal, die Payment-Wall funktioniert auch ohne Webhooks.

  • valivali MitgliedKommentare: 26 Danke erhalten: 5 bearbeitet 11. Februar Mitglied seit: Mai 2018

    Hallo Moritz, auch dir danke für die Antwort.

    Das Problem ist gelöst bei mir! (zumindest im Testshop) Ein Update von 5.5.4 auf 5.5.6 hat geholfen. Alle Zahlungsarten werden wieder angezeigt. Im Liveshop werde ich das Update später aufspielen und berichten.

    edit: Nach Update auf 5.5.6 im Liveshop werden die Zahlungsarten von PayPal Plus nun auch wieder angezeigt Thumb-Up

  • artepartep MitgliedKommentare: 3530 Danke erhalten: 572 Mitglied seit: Juli 2010

    Wir haben das neue Plugin 2.1.0 seit dem 3.11. drin und es läuft super. Thumb-Up Warte jetzt nur noch auf den ersten Ratenkauf ob das auch so gut klappt.

  • ThalionThalion MitgliedKommentare: 6 Danke erhalten: 0 bearbeitet 12. Februar Mitglied seit: Mai 2018

    Bei mir leiderf nicht. Ich ändere die Adresse dann geht es einmal, dann ändere ich die Adresse nochmal (in die selbe) und dann geht es wieder nicht. Bei 70% funktioniert es nicht und dann wieder doch. Irgendwas knallt bei mir wahrscheinlich im Hintergrund. Vielleicht liegts am Theme, an den komplizierten Versandkostenberechnungen etc. Im alten Shop (5.2) hatte aber alles funktioniert. Bin echt sprachlos im Moment.

  • franco_123franco_123 MitgliedKommentare: 2 Danke erhalten: 0 Mitglied seit: 12. Februar

    Okay im Forum lesen hilft. Shopware 5.5.4 seit Update auch nur noch die "globale" Paypal Auswahl und keine Untersektionen mit Rechnungskauf etc.

    Also mal updaten... ;) das macht ja Hoffnung das es bei 5.5.6 gehen soll.

  • franco_123franco_123 MitgliedKommentare: 2 Danke erhalten: 0 Mitglied seit: 12. Februar

    Geht das Paypal Plus Plugin bei euch? Gestern nach dem update auf 5.5.6 ging es. Heute wieder nicht mehr ohne irgendwelche Änderungen.

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    Bei uns geht auch nur Globale Auswahl.

    Update haben wir (noch) nicht gemacht.

    Das ist wieder Supertoll ...

     

  • ThalionThalion MitgliedKommentare: 6 Danke erhalten: 0 Mitglied seit: Mai 2018

    Bei uns ist Paypal Plus auch immer noch ohne Funktion. 

    Wenn ich als Neukunde den normalen Checkout durchlaufen möchte und zur Zahlungsseite komme (Step 2) klappt es nicht mit dem bekannten Fehler. Gehe ich aber zurück und auf Warenkorb bearbeiten und dann weiter stehen mir die Zahlungsarten zur Verfügung.
    Unter https://www.DOMAINxyz/checkout/confirm klappt es, unter https://www.DOMAINxyz/checkout/shippingPayment nicht. Es kommt also darauf an wo im Checkout wir uns befinden.

    Alles sehr seltsam.

    Zu Step 2 habe ich das noch gefunden und ausprobiert "( Zahlungsart bei Bestellung immer auswählen: Wenn diese Option aktiv ist, werden auch Bestandskunden beim Checkout immer durch die Zahlartauswahl (Step2) geführt.)"Habe ich mal aktiviert und dann kommt man nur noch auf die Seite wo es nicht funktioniert.

  • Michael TelgmannMichael Telgmann ModeratorKommentare: 767 Danke erhalten: 235 Mitglied seit: Juni 2014

    Hallo zusammen,

    also wenn es auf der confirm Seite funktioniert und auf der shippingPayment Seite nicht, würde ich jetzt eine individuelle Template Anpassung vermuten. Sei es durch ein eigenes Theme oder ein anderes Plugin. Grundsätzlich scheint das Plugin ja zu funktionieren. 

    Viele Grüße aus Schöppingen

    cool Michael Telgmann

    Danke von 1Thalion
  • ThalionThalion MitgliedKommentare: 6 Danke erhalten: 0 Mitglied seit: Mai 2018

    Ja, möglicherweise liegt es am Update des GrestRedux Themes oder am Update eines Plugins, denn mit der alten Shopware Version und den alten Plugin Versionen hatte alles funktioniert. Mal sehen ob wir das Problem irgendwie orten können. Danke sehr an den Support !!!!Thumb-Up

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    Leider geht es nirgendwo! 

    image

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    Vor dem Update ging es tadellos, jetzt geht es nicht. Wir haben kein individuelles Tamplate. Standard halt.

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 6472 Danke erhalten: 1923 Mitglied seit: September 2013

    Also das Bild zeigt einen OnePageCheckout. Das hat überhaupt nichts mit dem Shopware Standard zu tun. Erstmal prüfen, wie das ohne das Plugin aussieht.

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    das ist ein tipp

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    Leider auch nicht..

    image

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    Der Expressbutton wird leider auch nicht mehr angezeigt

    image

  • artepartep MitgliedKommentare: 3530 Danke erhalten: 572 bearbeitet 13. Februar Mitglied seit: Juli 2010

    Wie habt Ihr das PP-Plugin denn eingestellt? Unter PP Plus Integration sollte die Anzeige aktiviert sein.

     

     

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    Bei uns läuft die Vers. 5.5.4

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 6472 Danke erhalten: 1923 Mitglied seit: September 2013

    Dann am besten mal alles deaktivieren, also alle Plugins die nicht Standard sind und das Standard Theme aktivieren (Responsive) und nochmal testen.

    Kann man am besten in einer Testumgebung machen. 
     

  • Bohrerdiscount24Bohrerdiscount24 MitgliedKommentare: 29 Danke erhalten: 0 Mitglied seit: Oktober 2015

    ja, alles korrekt eingestellt und getestet

    image

  • AutoFrauAutoFrau MitgliedKommentare: 146 Danke erhalten: 4 Mitglied seit: Januar 2016

    Gleiches Problem hier, ebenfalls behoben durch Update auf 5.5.6, wie @vali‍ schon sagte. Danke für den Tipp. Thumb-Up

  • artepartep MitgliedKommentare: 3530 Danke erhalten: 572 Mitglied seit: Juli 2010

    Wir haben in den Logs auch einige Fehler drin, obwohl PP bei uns läuft, aber wohl doch nicht immer Frown:

    plugin.ERROR: PayPal: Could not process checkout due to a communication failure {"message":"Shopware Order Fatal-Error www.meinshop.de :SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'paymentID' cannot be null"} {"uid":"1d4f658"}

    oder 

    plugin.ERROR: PayPal: Could not obtain payment details due to a communication failure {"message":"Client error response [url] https://api.paypal.com/v1/payments/payment/PAYID-LRM4CMI40S613815L883444V [status code] 404 [reason phrase] Not Found","payload":"{\"name\":\"INVALID_RESOURCE_ID\",\"message\":\"The requested resource ID was not found\",\"information_link\":\"https://developer.paypal.com/docs/api/payments/#errors\",\"debug_id\":\"df0aafb5b506\"}"} {"uid":"ff041c7"}

     

    Was mir aufgefallen ist: Die Standardzahlungart stand bis eben noch auf der alten ID, das ist jetzt bei mir 323. Hab auch mal Bestellnummer übergeben deaktiviert. In der Vergangenheit gab es dadurch ja auch Probleme. Keine Ahnung ob das was mit den Fehlern zu tun hat.  Mal schauen was jetzt so passiert.

Anmelden oder Registrieren, um zu kommentieren.