uscreenuscreen MemberComments: 0 Received thanks: 0 Member since: March 2016

Hallo zusammen,

wir haben derzeit das Problem, dass über die Shopware Themenkonfiguration kein SVG Logo eingunden werden kann.

Wird dieses probiert, wird kein Logo und kein Fehler ausgegeben.

Hat jemand ein ähnliches Problem und evtl. eine Lösung für das Verhalten?

Shopware Version: 5.4.5

Comments

  • MurmeltierMurmeltier MemberComments: 905 Received thanks: 162 Member since: April 2017

    Also ich verwende ausschließlich SVG (V 1.1) Logos und habe damit keine Probleme. Welche Version SVG benutzt Du denn bzw. wie erstellst Du so ein SVG?

  • 27nudeln27nudeln MemberComments: 8 Received thanks: 0 Member since: October 2018

    Hallo Uscreen, habt ihr eine Lösung gefunden? Ich stehe gerade vor dem gleichen Problem Frown. Shopversion 5.5.2

    Danke!

  • christiantradechristiantrade MemberComments: 267 Received thanks: 51 Member since: July 2017

    In die Console geschaut im Frontend?

    Evtl. braucht das svg Logo noch nen display: block; und/oder breite/höhe.

  • PixzlPixzl MemberComments: 1 Received thanks: 0 edited November 8 Member since: October 23

    Da dieses Problem scheinbar noch nicht gelöst ist - hier mal unsere Lösung:

    Meist liegt es - wie @christiantrade‍ schon sagt - daran, dass irgendetwas nicht richtig definiert ist.

    So sind bspw. wir vorgegangen:
    In der index.tpl ('themes/Frontend/Dein-Theme/frontend/index/index.tpl') folgenden Block hinzufügen:

    {block name='frontend_index_logo_container'}
    <div class="logo-main block-group" role="banner">
            <div class="logo--shop block">
            <a class="logo--link" href="https://www.DEINE-DOMAIN.de/"; title="DEIN TITEL - zur Startseite wechseln">
                <picture class="svg-logo-nav">   
                    <source srcset="https://www.DEINE-DOMAIN.de/media/vector/0c/a4/cb/DEINE.svg"; media="(min-width: 78.75em)">      
                    <source srcset="https://www.DEINE-DOMAIN.de/media/vector/0c/a4/cb/DEINE.svg"; media="(min-width: 64em)">
                    <source srcset="https://www.DEINE-DOMAIN.de/media/vector/0c/a4/cb/DEINE.svg"; media="(min-width: 48em)">
                    <img srcset="https://www.DEINE-DOMAIN.de/media/vector/0c/a4/cb/DEINE.svg"; alt="DEIN TITEL - zur Startseite wechseln">
                </picture>
            </a>
        </div>
    </div>
    {/block}

     

    Dem Tag haben wir die Klasse  "svg-logo-nav" gegeben und diese in der CSS Datei wie folgt definiert:

    .svg-logo-nav {
        display: block;
        width: 120px; /*Je nachdem, welche Breite das Logo haben soll.*/
    }

     

  • MurmeltierMurmeltier MemberComments: 905 Received thanks: 162 edited November 8 Member since: April 2017

    Warum so kompliziert? Einfach SVG in den Medienmanager laden und dann im Theme Manager auswählen. Dann noch 3 Zeilen CSS Code - zwecks Größeanpassungen im Frontend - und gut ist. So hab ich das zumindest damals gemacht und so funktioniert es auch bis heute...

  • kullikulli MemberComments: 2010 Received thanks: 312 Member since: August 2013
Sign In or Register to comment.