rmaassenrmaassen MitgliedKommentare: 8 Danke erhalten: 0 Mitglied seit: Dezember 2016

Hallo Community,

nach der Installation von BS PAYONE kommt es bei der Neukundenregistrierung zu einem Fatal Error:

Fatal error: Uncaught Exception: DateTime::__construct(): Failed to parse time string (NULL) at position 0 (N): The timezone could not be found in the database in /var/www/xxx/var/cache/production_201801171346/doctrine/attributes/Customer.php:123 Stack trace: #0 /var/www/xxx/var/cache/production_201801171346/doctrine/attributes/Customer.php(123): DateTime->__construct('NULL') #1 /var/www/xxx/vendor/symfony/form/Extension/Core/Type/FormType.php(136): Shopware\Models\Attribute\Customer->__construct() #2 /var/www/xxx/vendor/symfony/form/Form.php(617): Symfony\Component\Form\Extension\Core\Type\FormType->Symfony\Component\Form\Extension\Core\Type\{closure}(Object(Symfony\Component\Form\Form), NULL) #3 /var/www/xxx/vendor/symfony/form/Form.php(577): Symfony\Component\Form\Form->submit(Array, true) #4 /var/www/xxx/engine/Shopware/Controllers/Frontend/Register.php(465): Symfony\Component in /var/www/xxx/var/cache/production_201801171346/doctrine/attributes/Customer.php on line 123

Suche im Forum und bei Google half leider nicht weiter.
Kann hier jemand helfen?

Ich stehe für Fragen natürlich zur Verfügung und freue mch über jede Hilfe oder Anregung zur Selbsthilfe.

Viele Grüße
Robert Maaßen

Kommentare

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 6186 Danke erhalten: 1828 Mitglied seit: September 2013

    Sieht mir auf den ersten Blick nach einem Problem des Plugins und einem Datumsformat aus. Hast du denn mal Payone kontaktiert?

  • rmaassenrmaassen MitgliedKommentare: 8 Danke erhalten: 0 Mitglied seit: Dezember 2016

    Ja. Warte dort noch auf Antwort.

  • rmaassenrmaassen MitgliedKommentare: 8 Danke erhalten: 0 Mitglied seit: Dezember 2016

    Antwort von PAYONE:
    "Die Benutzerverwaltung an sich ist nicht Teil des PAYONE Moduls. Der Pfad, auf den in der Exception verwiesen wird, scheint auf die Shopwareinstallation direkt hinzudeuten. Wir möchten Sie daher darum bitten, sich mit diesem Problem direkt an den Support von Shopware zu wenden. Vielen Dank."

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 6186 Danke erhalten: 1828 Mitglied seit: September 2013

    Hast du das Plugin denn mal deaktiviert und dann mal eine Registrierung getestet?

    Scheint ein Freitextfeld mit Datumswert zu sein. Hast du da was angelegt?

  • rmaassenrmaassen MitgliedKommentare: 8 Danke erhalten: 0 Mitglied seit: Dezember 2016

    Ja. Bei deaktiviertem Plugin funktioniert die Registrierung ebenfalls nicht.

    Die Zeile auf die im Fehler verwiesen wird ist diese:
    $this->moptPayoneConsumerscoreDate = new \DateTime("NULL");

    Es wurden durch das Plugin Freitextfelder angelegt:

  • rmaassenrmaassen MitgliedKommentare: 8 Danke erhalten: 0 Mitglied seit: Dezember 2016

    Was kann ich denn tun um diesen Fehler zu beseitigen? 
    PAYONE hat sich bisher nicht wieder zurück gemeldet.

  • Cathrin_PAYONECathrin_PAYONE MitgliedKommentare: 12 Danke erhalten: 0 Mitglied seit: Mai 2016

    Hallo @rmaassen‍,

    Shopware hat sich mit uns in Verbindung gesetzt und wir arbeiten mit Hochtouren an einer Lösung des Problems.

    Unser Kundenservice wird sich schnellstmöglich mit Ihnen in Verbindung setzen.

    Bei Fragen wenden Sie sich auch gerne an mich.

    Viele Grüße 

    Cathrin von BS PAYONE

  • rmaassenrmaassen MitgliedKommentare: 8 Danke erhalten: 0 Mitglied seit: Dezember 2016

    @Cathrin_PAYONE‍ Danke. Ich warte sehnsüchtig und freue mich auf Antwort :-)

  • dondon MitgliedKommentare: 161 Danke erhalten: 13 Mitglied seit: Januar 2011

    Ist das ein generelles Problem? Wir setzen auch das Plugin ein. Ich kann derzeit keinen Fehler reproduzieren bei einer Neukunden Registrierung.

  • Cathrin_PAYONECathrin_PAYONE MitgliedKommentare: 12 Danke erhalten: 0 Mitglied seit: Mai 2016

    Hallo @rmaassen‍, unser Kundenservice hat Ihnen mittlerweile schon eine E-Mail mit weiteren Informationen zukommen lassen. Ich hoffe, dass Sie das Problem nun schnall beheben können. @don‍ Es handelte dich um ein individuelles Problem. Der Fehler tritt bei Ihnen nicht auf.

    Bei Fragen kommen Sie gerne auf mich zu.

    Viele Grüße

    Cathrin von BS PAYONE

  • st20dst20d MitgliedKommentare: 4 Danke erhalten: 0 bearbeitet 24. Juli Mitglied seit: 22. Juni

    Das gleiche Problem tritt bei uns nun auch auf.

    Eine tel. Anfrage bei BS PAYONE wurde mit "eMail Bearbeitung dauert min. 3 Tage" beantwortet. Wir benötigen hier dringend eine Lösung. 

  • Cathrin_PAYONECathrin_PAYONE MitgliedKommentare: 12 Danke erhalten: 0 Mitglied seit: Mai 2016

    Hallo @st20d‍,

    bitte wenden Sie sich direkt an unseren Technischen Support per E-Mail tech.support@bspayone.com oder telefonisch unter 0431-25968-500. Die Kollegen helfen Ihnen schnellstmöglich weiter.

    Viele Grüße

    Cathrin von BS PAYONE

  • st20dst20d MitgliedKommentare: 4 Danke erhalten: 0 Mitglied seit: 22. Juni

    Hallo Cathrin,

    danke für den Hinweis. Das habe ich bereits gestern getan, mit dem oben genannten Hinweis "eMail Bearbeitung dauert min. 3 Tage".

    Viele Grüße
    Rene

  • Cathrin_PAYONECathrin_PAYONE MitgliedKommentare: 12 Danke erhalten: 0 Mitglied seit: Mai 2016

    Hallo Rene,

    die Kollegen habe mir gerade mitgeteilt, dass Ihnen schon weitergeholfen wurde.
    Bitte kontaktieren Sie uns auch gerne direkt, wenn Sie noch weitere Hilfestellung benötigen oder Fragen haben.

    Viele Grüße

    Cathrin von BS PAYONE

  • fabianknorrfabianknorr MitgliedKommentare: 106 Danke erhalten: 0 Mitglied seit: Dezember 2011

    Gab es hierzu einen Lösungsweg? Der Fehelr tritt bei uns auch auf seit heute? 

    Fatal error: Uncaught Exception: DateTime::__construct(): Failed to parse time string (NULL) at position 0 (N): The timezone could not be found in the database in /var/www/clients/client1/web2/web/var/cache/production_201801171346/doctrine/attributes/Customer.php:153 Stack trace: #0 /var/www/clients/client1/web2/web/var/cache/production_201801171346/doctrine/attributes/Customer.php(153): DateTime->__construct('NULL') #1 /var/www/clients/client1/web2/web/vendor/symfony/form/Extension/Core/Type/FormType.php(136): Shopware\Models\Attribute\Customer->__construct() #2 /var/www/clients/client1/web2/web/vendor/symfony/form/Form.php(617): Symfony\Component\Form\Extension\Core\Type\FormType->Symfony\Component\Form\Extension\Core\Type\{closure}(Object(Symfony\Component\Form\Form), NULL) #3 /var/www/clients/client1/web2/web/vendor/symfony/form/Form.php(577): Symfony\Component\Form\Form->submit(Array, true) #4 /var/www/clients/client1/web2/web/engine/Shopware/Controllers/Frontend/Register.php(465): Symfony\Component\Form\Form->submit in /var/www/clients/client1/web2/web/var/cache/production_201801171346/doctrine/attributes/Customer.php on line 153

     

  • Cathrin_PAYONECathrin_PAYONE MitgliedKommentare: 12 Danke erhalten: 0 Mitglied seit: Mai 2016

    Hallo @fabianknorr‍, leider können wir den Fehler bei uns so nicht reproduzieren. Mögen Sie sich einmal an unseren Technical Support unter  tech.support@bspayone.com oder telefonisch unter 0431-25968-500. Die Kollegen helfen Ihnen schnellstmöglich weiter.

    Viele Grüße

    Cathrin von BS PAYONE

  • artepartep MitgliedKommentare: 3486 Danke erhalten: 561 bearbeitet 7. Dezember Mitglied seit: Juli 2010

    Wir hatten letzte Woche auch plötzlich diesen Fehler obwohl wir das Plugin "nicht" einsetzen. Wir mussten es komplett löschen und danach funktionierte alles wieder. Warum, wieso, weshalb wissen wir bis heute nicht. 

Anmelden oder Registrieren, um zu kommentieren.