ShumuuShumuu MitgliedKommentare: 22 Danke erhalten: 1 Mitglied seit: Juli 2017

Guten Tag liebe Community,

vor kurzem wollten wir wieder amazon payment in unserem Shop anbieten. Dafür reaktivierte ich das amazon payment Plugin, wusste aber nicht dass es veraltet ist (die legacy Version von best it).

Als ich es geupdatet habe, habe ich den Fehler bemerkt und es deinstalliert.

Am nächsten Tag schaute ich in den System-Log und sah folgenden Fehler alle paar minuten aufoppen

Date: 2018-02-05 11:10:40 Message: Missing token. Token is not set in Configuration service.

Date: 2018-02-05 11:10:40 Message: {"Message":"Fail to start task execution.","TaskId":885,"ExceptionMessage":"Missing token. Token is not set in Configuration service."}

(Die TaskId erhöht sich immer um 1)

Dieser Fehler scheint den Shop nicht zu beeinträchtigen (soweit wir wissen ..)  Der Fehler trat in etwa eine Viertelstunde nach dem Updaten und deinstallieren des Plugins auf, und da dass das einzige war was ich am Tag im Shop gemacht habe, führe ich es auf das Plugin zurück.

 

Hat jemand vielleicht eine Ahnung woran es liegen kann und wie ich den Fehler beheben könnte ? 

 

Beste Grüße

Shumuu

 

 

Antworten

  • gentlemediagentlemedia MitgliedKommentare: 91 Danke erhalten: 6 Mitglied seit: März 2012

    Ich habe diesen Fehler hier auch in einem Log und finde die Ursache nicht.

    Wie kommst Du darauf, dass es am bestit amazon Plugin liegt, wenn das bei dir doch deinstalliert ist?

  • ShumuuShumuu MitgliedKommentare: 22 Danke erhalten: 1 bearbeitet 5. Februar Mitglied seit: Juli 2017

    Weil ich bevor ich das Plugin aktiviert und geupdatet habe, diese Fehler NICHT hatte. Die kamen erst nachdem ich es aktiviert und geupdatet habe (aber eben auch erst ~15 minuten danach). Da dies die einzige (für mich sichtbare) Erneuerung war, scheint es mir das zu sein. Sicher bin ich mir aber nicht.

     

    Dachte vielleicht an einen cron job o.ä. der nun immer wieder aufgerufen wird. Das Plugin sprach davon dass der Shop voll SSL fähig sein muss, dafür hat er vielleicht ein cron job ? Wer weiß ...

  • gentlemediagentlemedia MitgliedKommentare: 91 Danke erhalten: 6 Mitglied seit: März 2012

    Ist bei Dir im Shop csrfProtection deaktiviert?

  • ShumuuShumuu MitgliedKommentare: 22 Danke erhalten: 1 Mitglied seit: Juli 2017

    Derzeit ja, weil wir noch auf der 5.2.18 Version hängen, die den miesen csrf Fehler hat

  • gentlemediagentlemedia MitgliedKommentare: 91 Danke erhalten: 6 Mitglied seit: März 2012

    Ich habe eben gesehen, dass an dem betreffenden Shop noch das csrfProtection deaktiviert war, weil es damit früher Probleme gab (die jetzt hoffentlich behoben sind). 

    Das habe ich jetzt aktiviert und seit einigen Minuten diese Meldung nicht mehr erhalten. Kann aber auch Zufall sein.

  • ShumuuShumuu MitgliedKommentare: 22 Danke erhalten: 1 Mitglied seit: Juli 2017

    Bei mir sind auch häufig bis zu 30 minuten Pause zwischen den Fehlern (vielleicht auch länger), meld dich wenn der Fehler wieder kommt.

  • gentlemediagentlemedia MitgliedKommentare: 91 Danke erhalten: 6 Mitglied seit: März 2012

    Ok, das war es nicht, Fehler scheint bei jeder Bestellung zu entstehen und mittags ist es in dem Shop ruhig.

    Darf ich fragen, ob Du ein Klarna Plugin benutzt?

  • ShumuuShumuu MitgliedKommentare: 22 Danke erhalten: 1 bearbeitet 5. Februar Mitglied seit: Juli 2017

    Wir benutzen kein Klarna Plugin :/

     

    Bei uns ist es definitiv unabhängig von den Bestellungen

  • it-brockmannit-brockmann MitgliedKommentare: 26 Danke erhalten: 4 Mitglied seit: Mai 2015

    Hallo,

    wir haben gestern das erste Mal diese Fehler erhalten. Gibt es dazu schon einen Ansatz?

    Message: Missing token. Token is not set in Configuration service.

  • gentlemediagentlemedia MitgliedKommentare: 91 Danke erhalten: 6 Mitglied seit: März 2012

    Was genau habt Ihr vor dem ersten Auftreten der Meldung geändert?

  • ShumuuShumuu MitgliedKommentare: 22 Danke erhalten: 1 Mitglied seit: Juli 2017

    Wir haben die legacy Plugin Version von Amazon Pay (von best it) aktualisiert (und aktiviert), und dann deinstalliert (weil es eben veraltet ist). Das war ca 15 minuten vor auftreten der ersten Meldung.

  • rory_chrory_ch MitgliedKommentare: 4 Danke erhalten: 0 Mitglied seit: August 2017

    Bei uns ist mir diese Meldung soeben auch aufgefallen.

    Weiss aber auch noch nicht genau, von wo diese stammt.
    Hat da schon jemand mehr dazu herausgefunden?

    Wir haben Shopware 5.2.27 und kein Amazon aber dafür das Klarna Plugin.

  • sunflowersunflower MitgliedKommentare: 172 Danke erhalten: 6 Mitglied seit: September 2012

    Ich habe diese Meldung nun auch. Tritt auf nach einem Update von 5.2.6 nach 5.3.7.

  • vc-nmvc-nm MitgliedKommentare: 44 Danke erhalten: 8 Mitglied seit: August 2013

    ich klink mich mal ein, hab das auch seit kurzem in meinen Shops!

Anmelden oder Registrieren, um zu kommentieren.