MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015 bearbeitet Oktober 2017

Scheinbar ist seit kurzem der Ioncube Loader für PHP 7.1 verfügbar. Meine letzten Downloads dazu (https://www.ioncube.com/loaders.php) vom 15.06.2017 und 12.07.2017 enthielten noch keine ioncube_loader_lin_7.1.so Files.

Seit dem Update von gestern scheinen diese erstmals inkludiert zu sein - heute Abend teste ich mal ob der Spass mit der neusten PHP 7.1 Version und Premium Plugins funktioniert.

Weiß da jemand mehr? Gibt es die Version schon länger? Finde die Kommunikation von Ioncube immer sehr dürftig...

 

PS:

2nd Aug 2017 - Loader 10.0.0 released 
Loader 10.0.0 released. 
These are loaders to run files produced by the forthcoming version 10 ionCube PHP Encoder.
Included are loaders for PHP 7.1. Those will only run files produced by
the version 10 encoder for PHP 7.1.

 

 

 

Kommentare

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 5658 Danke erhalten: 1608 Mitglied seit: September 2013

    Gibt es glaube ich seit Ende August bereits. Steht zumindest hier: https://www.ioncube.com/news.php

    Unsere Plugins (Premium-Plugins) brauchen den Loader ja schon ab 5.2 nicht mehr. Den brauchst du nur für verschlüsselte Plugins aus dem Store und den Lizenz-Manager (wird bei unseren Plugins auch nicht benötigt). Allerdings sind die aktuellen Pakete die du verschlüsselt über den Community Store bekommst, noch nicht mit PHP7.1 kompatibel. Wie du bereits erkannt hast, ist die Kommunikation von Ioncube sehr dürfig. Wir sind gerade in Gesprächen, inwieweit man die Verschlüsselung im Store anpassen muss, damit wir auch PHP7.1 + ioncube unterstützen können.

    Die neuste Loader-Version + php7.0 funktioniert auch mit den Paketen aus dem Store, nur die Lösung ioncube + php7.1 nicht (obwohl die gleiche Loader Version genutzt wird).

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015

    Hallo Moritz,

    schade. Hatte mich schon darauf gefreute endlich PHP 7.1 einsetzen zu können. Ihr verschickt dann sicher einen NL o.Ä. sobald PHP 7.1 genutzt werden kann, ja?

     

     

  • pemmlerpemmler MitgliedKommentare: 410 Danke erhalten: 59 Mitglied seit: Januar 2015

    Und warum? Was bringt dir 7.1. mehr?

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015
  • timomayertimomayer MitgliedKommentare: 30 Danke erhalten: 6 Mitglied seit: August 2014

    Gibt es hier schon etwas neues? Da ioncube nun endlich mal in die Pötte gekommen ist würde ich wirklich gerne auf Php 7.1 updaten! 

  • PixelcorePixelcore MitgliedKommentare: 13 Danke erhalten: 0 Mitglied seit: Juli 2015

    Würde mich auch interessieren!

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 5658 Danke erhalten: 1608 Mitglied seit: September 2013

    Das wird sich wohl noch etwas hinziehen. Ich schau die Tage mal, ob ich den aktuellen Stand rausbekomme.

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015

    Hi @Moritz Naczenski‍ hast du hier schon Neuigkeiten?

  • RaubfischfreundRaubfischfreund MitgliedKommentare: 19 Danke erhalten: 0 Mitglied seit: Januar 2017

    Gibts was neues? 

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015

    Interessant, habe auch gerade daran gedacht... Gibt es hier Neuigkeiten? @Moritz Naczenski

  • jore87jore87 MitgliedKommentare: 1 Danke erhalten: 0 Mitglied seit: November 2017

    Da ich gerade im Moment darüber stolpere (DHL Anbindung PHP 7.1 <> Ioncube) würde mich auch interessieren, ob es hier nen neuen Stand gibt

  • berggeistberggeist MitgliedKommentare: 10 Danke erhalten: 0 Mitglied seit: September 2017

    Hallo,

    auch mich würde es interesieren ob es einen neuen Stand gibt. 
    Da ich egrade bei der Installation von ioncube bei PHP-Version 7.1.10 hänge.

     

    Vielen Dank!

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015

    PHP 7.2.0 wurde vor kurzem released... http://php.net/archive/2017.php#id2017-11-30-1

    Wie ist hier der Stand?

     

  • SBSB MitgliedKommentare: 134 Danke erhalten: 34 bearbeitet Dezember 2017 Mitglied seit: April 2015

    Warum die Eile ? Wenn die Kompatibilität zu 7.1 (siehe diverse Posts im Forum) nicht gegeben ist, warum sollte sich das mit 7.2 ändern?.

    Shopware ist mit PHP 7.0.xx kompatibel. Nimm' 7.0.xx und alles ist gut.

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 bearbeitet 7. Februar Mitglied seit: Dezember 2015

    Warum die Eile ? Wenn die Kompatibilität zu 7.1 (siehe diverse Posts im Forum) nicht gegeben ist, warum sollte sich das mit 7.2 ändern?.

    Shopware ist mit PHP 7.0.xx kompatibel. Nimm' 7.0.xx und alles ist gut.

    Was meinst du mit Kompatibilität nicht gegeben? Shopware läuft einwandfrei mit 7.1 ohne verschl. Plugins. Es ging mir mit dem Post darum darauf hinzuweisen, dass bereits PHP7.2 released wurde und es immer noch keinen Ioncube Verschlüsselung mit Version 10 gibt. 

  • indigoindigo MitgliedKommentare: 87 Danke erhalten: 7 bearbeitet 7. Februar Mitglied seit: Oktober 2015

    Gibt es denn keinen alternativen PHP Encoder? 

    Oder SW integriert einen eigenen Decoder in den Lizenzmanager.

  • derwunnerderwunner MitgliedKommentare: 304 Danke erhalten: 61 Mitglied seit: Januar 2017

    Gibt es denn keinen alternativen PHP Encoder? 

    Oder SW integriert einen eigenen Decoder in den Lizenzmanager.

    Soviel ich weiß gibt es keine Alternative. Ist im Normalfall auch eine exotische Erweiterung.

    Sobald du anfängst einen Encoder in Shopware zu integrieren ist es wieder PHP, dann kannst es dir auch gleich sparen. Ein Encoder muss irgendwie kompilieren, und das erreicht man nur in Form einer PHP Extension. 

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 bearbeitet 8. Februar Mitglied seit: Dezember 2015

    Wenn jede Versionsanpassung so lange dauert, sollte man sich eventuell nochmal überlegen ob das der richtige Weg ist. Wo liegt eigentlich aktuell das Problem @ShopwareTeam ? Sind es Inkompatibilitäten? Testing? Nicht in der Planung da nicht Urgent? Lizenzproblem mit Ioncube?

    Edit: Habe nochmal gelesen was Moritz vor 4-5 Monaten geschrieben hat. Scheint an der Rückmeldung von Ioncube zu liegen. Der Encoder scheint ja nicht sehr flexibel zu sein - schon komisch.

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015

    @Moritz Naczenski‍ konntest du was herausfinden?

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 5658 Danke erhalten: 1608 Mitglied seit: September 2013

    @Moritz Naczenski‍ konntest du was herausfinden?

    Siehe: https://forum.shopware.com/discussion/comment/212094/#Comment_212094

    Kurzfristig wird es da also nichts geben. 

  • MisengoMisengo MitgliedKommentare: 191 Danke erhalten: 19 Mitglied seit: Dezember 2015

    @Moritz Naczenski‍ vielen Dank. Wenn Ioncube da an keinem Lösungsweg interessiert ist, wird es vermutlich dann Sinn machen über versch. Downloads nachzudenken - Ioncube bietet ja beim Download des decoders ebenfalls versch. Versionen an - so müsste es dann für die Plugins ebenfalls sein und der Endkunde wählt dann seinen Ordner (5.6 / 7.0 / 7.1 / 7.2 etc.) Sicherlich keine einfache Aufgabe, aber wenn der Prozess einmal erstellt wurde, sollte das ja automatisiert passieren. Oder werden die Plugins händisch analyisiert und decoded?

     

     

     

     

Anmelden oder Registrieren, um zu kommentieren.