MIRR_DEMIRR_DE MitgliedKommentare: 82 Danke erhalten: 4 Mitglied seit: Dezember 2015

Ich habe bei mir noch das Shopware Plugin "Automatische Sprachshop-Auswahl" installiert. Es wird eigentlich nicht benötigt und ich wollte es im Zuge einer Bereinigung für das 5.3 Update deinstallieren. Leider erhalte ich danach folgende Fehlermeldung im Frontend:

Fatal error: Uncaught SmartyException: directory '/[...]/engine/Shopware/Plugins/Community/Frontend/SwagBrowserLanguage/Views/responsive/frontend/index/index.tpl' not allowed by security setting in /[...]/engine/Library/Smarty/sysplugins/smarty_security.php:381 Stack trace: #0 /[...]/engine/Library/Smarty/sysplugins/smarty_internal_resource_file.php(33): Smarty_Security->isTrustedResourceDir('/var/www/vhosts...') #1 /[...]/engine/Library/Smarty/sysplugins/smarty_resource.php(532): Smarty_Internal_Resource_File->populate(Object(Smarty_Template_Source), NULL) #2 /[...]/engine/Library/Smarty/sysplugins/smarty_internal_resource_extends.php(41): Smarty_Resource::source(NULL, Object(Enlight_Template_Manager), '/var/www/vhosts...') #3 /var/www/vhost in /[...]/engine/Library/Smarty/sysplugins/smarty_security.php on line 381

Das Plugin muss mindestens installiert sein (nicht aktiviert), damit der Fehler nicht mehr auftritt.

Kann mir hier jemand helfen das zu beheben?

Danke schön.

Viele Grüße,
Manuel

1 Antwort

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 4507 Danke erhalten: 1207 Mitglied seit: September 2013

    Der Fehler kommt vor oder nach dem Update?
    Das Plugin muss vor dem Update entfernt  und sollte dann auch komplett vom Server gelöscht werden.

    Zitieren
    Akzeptierte Antwort
  • Akzeptierte Antwort

Antworten

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 4507 Danke erhalten: 1207 Mitglied seit: September 2013

    Der Fehler kommt vor oder nach dem Update?
    Das Plugin muss vor dem Update entfernt  und sollte dann auch komplett vom Server gelöscht werden.

    Zitieren
    Akzeptierte Antwort
  • MIRR_DEMIRR_DE MitgliedKommentare: 82 Danke erhalten: 4 Mitglied seit: Dezember 2015

    Der Fehler kommt nach dem Update. Ich hatte auf meiner Testumgebung das Plugin erst später entfernt.

    Wenn der Fehler dann nicht mehr auftritt, dann entferne ich in der Live-Umgebung das Plugin im Vorfeld.

Anmelden oder Registrieren, um zu kommentieren.