SynonymousSynonymous MitgliedKommentare: 450 Danke erhalten: 73 Mitglied seit: Juli 2016

Schönen guten Morgen zusammen,

Wir haben seit dem Umstieg auf Shopware Probleme mit den Kunden-Sessions während der Zahlung. In regelmäßigen Abständen wird beim Bestellprozess während der Bezahlung scheinbar im Hintergrund die Shopware-Session zerstört. Der Kunde kommt nach dem Zahlugsvorgang (zB. PayPal) wieder in den Shop, wo seine Session nicht mehr gefunden und somit die Order nicht angelegt wird.

Mein aktueller Wissenstand nach meiner Analyse anhand der Log-Daten ist:

  • Der Kunde kommt definitiv wieder zurück in den Shop aber die Session wird nicht gefunden
  • Es kann kein Timeout sein - die Zahlungsvorgänge bei den problematischen Order waren im Schnitt in unter 5 Minuten erledigt
  • Das die Session im Hintergrund manuell durch den User zerstört wird (Cookie löschen, ausloggen o.ä.) halte ich für ausgeschlossen, da es mit wiederkehrender Regelmäßigkeit mehrmals täglich auftritt.

Mein Verdacht:

  • Heute hatten wir einen Kunden, der zwei mal binnen 10 Minuten bestellt hat. Beide male ist (nur bei diesem Kunden) das Session Problem aufgetreten. Kann es sein, dass bestimmte Browser-Settings dafür sorgen, dass bei einem Redirect die "alten" Cookies / Sessions gelöscht werden?
  • Die Garbage Collection entsorgt alte Sessions nicht korrekt, was ich aber aufgrund der heutigen Doppel-Bestellung eher ausschließen würde.

Hat jemand von Euch vielleicht noch eine Idee was hier dahinter stecken könnte?

Danke & liebe Grüße!

Kommentare

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 4091 Danke erhalten: 1071 Mitglied seit: September 2013

    Könnte ein Problem im Zusammenhang mit dem "Sicheren Zahlungsverkehr" von Kaspersky sein. Da wird der Zahlungsvorgang in einem neuen Browserfenster geöffnet und da fehlt natürlich die Session. Könntest ja mal in die Access-Logs schauen, oib der User-Agent sich ändert.

  • hhmarco73hhmarco73 MitgliedKommentare: 66 Danke erhalten: 9 Mitglied seit: Juli 2016

    Wir hatten ein ähnliches Problem, allerdings nicht direkt mit PayPal. Ggf. einmal die session.gc_maxlifetime erhöhen. Wir hatten den default Wert von 24 Minuten nicht angepasst. Jetzt nach der Anpassung auf 60 Minuten vor einigen Wochen scheint das Problem gelöst zu sein.

  • SynonymousSynonymous MitgliedKommentare: 450 Danke erhalten: 73 Mitglied seit: Juli 2016

    @Moritz Naczenski‍ Danke, guter Hinweis - werde ich prüfen

    @hhmarco73‍ Schließe ich wie oben beschrieben eher aus... Zwischen Start der Transaktion und Rückkehr des Kunden vergehen weniger als 5 Minuten. Der Timeout steht bei uns bereits auf 60 Minuten.

Anmelden oder Registrieren, um zu kommentieren.