User_JDUser_JD MitgliedKommentare: 0 Danke erhalten: 0 Mitglied seit: 8. Mai

Ich habe Shopware lokal mit XAMPP installiert, kann aber leider das Plugin aus Kapitel 5.2, dass einen weiteren Reiter mit FAQ auf der Produktdetailseite anzeigen soll, nicht zum laufen kriegen. Mit dem Shopware-profiler Plugin wird mir angezeigt, dass das Templateverzeichniss korrekt ist und die nötigen Variablen zur Verfügung stehen, allerdings wird die Templatedatei frontend/detail/tabs.tpl nicht um die tpl Datei aus dem Ordner custom/plugins/LoremQuestions/Resources/Views/frontend/detail/tabs.tpl erweitert. Habe ich etwas Wichtiges vergessen, gibt es Probleme mit der Shopwareversion, der Templatestruktur? Den Code habe ich um Tippfehler zu vermeiden, von der Rheinwerkseite übernommen. Über jeden Hinweis freue ich mich sehr.

Antworten

  • Daniel NögelDaniel Nögel ModeratorKommentare: 1523 Danke erhalten: 360 Mitglied seit: September 2012

    Hi,

    habe mir das gerade angesehen: 

    image

    Genutzt habe ich hier das Code-Beispiel aus 5.2.7. Habe den Code in das Verzeichnis custom/plugins/LoremQuestions gezogen und das Plugin über die Konsole mit sw:plugin:refresh und sw:plugin:install --activate LoremQuestions installiert und aktiviert. Nach dem Leeren des Templates-Caches wurde die Änderung direkt angezeigt.

    Hast du die Schritte auch alle durchgeführt? Einen generellen Fehler sehe ich da gerade zumindest nicht.

    Schönen Gruß,

    Daniel

  • jürgenMjürgenM MitgliedKommentare: 5 Danke erhalten: 0 Mitglied seit: 21. Juni

    Hallo, habe das gleiche Problem mit dem XAMPP.  Das Code-Beispiel aus 5.2.7. funktionert Local nicht aber auf dem Liveserver geht es. Können da irgendwelche Einstellungen des Servers Schuld sein?

  • Daniel NögelDaniel Nögel ModeratorKommentare: 1523 Danke erhalten: 360 Mitglied seit: September 2012

    Hi,

    schwer einzuschätzen, Shopware ist ja für XAMPP / Windows nicht optimiert, gerade in Sachen Templating und Verzeichnisseparatoren gab es da immer wieder mal Probleme. Von daher empfehlen wir in aller Regel eher Setups mit Vagrant oder anderen Virtualisierungstechnologien, wenn lokal unter Windows entwickelt wird, gerade auch, weil das ja letztlich auf Produktion dann auf einer Linux-Umgebung läuft. 

    Besten Gruß,

    Daniel

    Danke von 1jürgenM
Anmelden oder Registrieren, um zu kommentieren.