TomL.TomL. MitgliedKommentare: 3 Danke erhalten: 1 Mitglied seit: Juli 2015

Hi,

ich habe für unseren Produkt-Export-Feed gemäß http://community.shopware.com/Produktexporte_detail_814.html die Standard-Bild-URL gegen die Variantenspezifische getauscht.

Mein Feed sieht so aus:

{assign var="string" value=$sArticle.articleID|articleImages:$sArticle.ordernumber:2:"##"|escape}
{assign var="productVariantImage" value="##"|explode:$string}
{strip}
{$sArticle.articleID|category:">"|escape|replace:"|":""}{#S#}
{$sArticle.supplier|replace:"|":""}{#S#}
{$sArticle.name|strip_tags|strip|trim|html_entity_decode|escape}{#S#}
{$sArticle.additionaltext}{#S#}
{$sArticle.price|escape:"number"}{#S#}
{if $sArticle.referenceunit && $sArticle.purchaseunit}
{assign var="sArticleReferenceprice" value=$sArticle.price/$sArticle.purchaseunit*$sArticle.referenceunit}
{$sArticle.referenceunit} {$sArticle.unit} = {$sArticleReferenceprice|escape:"number"}{#S#}
{$sArticle.purchaseunit} {$sArticle.unit}{#S#}
{else}
{#S#}{#S#}
{/if}
{$sArticle.suppliernumber|escape}{#S#}
{$sArticle.ean|escape}{#S#}
{#S#}
{#S#}
{$sArticle|@shippingcost:"cash":"de":"Deutsche Post Standard"|escape:"number"}{#S#}
{$sArticle|@shippingcost:"prepayment":"de":"Deutsche Post Standard"|escape:"number"}{#S#}
{$sArticle|@shippingcost:"debit":"de":"Deutsche Post Standard"|escape:"number"}{#S#}
{$sArticle.articleID|link:$sArticle.name|replace:"|":""}?number={$sArticle.ordernumber|replace:"|":""}{#S#}
{if $sArticle.instock}1-3{elseif $sArticle.shippingtime}{$sArticle.shippingtime|escape}{else}5{/if}{#S#}
{$sArticle.ordernumber|escape}{#S#}
{$productVariantImage[0]}{#S#}
{$sArticle.description_long|strip_tags|strip|trim|truncate:1000:"...":true|escape}
{/strip}{#L#}

 

Sobald ich die obige Variable hernehme, habe ich im CSV vor der korrekten URL zum Bild ein zusätzliches Anführungszeichen. So als würde ein String beginnen. Am Ende der URL kommt aber kein weiteres Anführungszeichen. Meines Erachtens gehört das erste schon nicht dahin, da die URLs ja eigentlich ohne Anfürhungszeichen im CSV sind.

Kann mir jmd. sagen, wo ich da den Fehler suchen muss?

Antworten

  • TomL.TomL. MitgliedKommentare: 3 Danke erhalten: 1 Mitglied seit: Juli 2015
    für die Nachwelt:
    {$productVariantImage[0]|replace:'"':''}
    
    damit funktioniert es bei uns...
    Danke von 1SK2017
  • SK2017SK2017 MitgliedKommentare: 11 Danke erhalten: 0 Mitglied seit: 9. August
    für die Nachwelt:
    {$productVariantImage[0]|replace:'"':''}
    
    damit funktioniert es bei uns...

    Firma dankt :)

Anmelden oder Registrieren, um zu kommentieren.