Umfrage zum Shopware Forum ›
phampham MitgliedKommentare: 14 Danke erhalten: 0 Mitglied seit: 6. März

Hallo zusammen,

ich habe die shopware vagrant box zusammen mit phpStorm als Entwicklungsumgebung eingerichtet. Wie im shopware - Handbuch für Entwickler beschrieben. 

Wenn ich aber das backend über  http://33.33.33.10/shopware/backend/  aufrufen möchte kommt folgender Fehler: 

Auf Ihrem Server läuft PHP version 5.5.9-1ubuntu4.21, Shopware 5 benötigt mindestens PHP 5.6.4

Bei meiner Suche bin ich dann auf diese Seite gestoßen: 

https://github.com/shopwareLabs/shopware-vagrant

Liefert folgende Infos: 

Make sure vagrant is at least at version 1.8:

$ vagrant -v

The following PHP Versions are installed by default:

  • PHP 5.6
  • PHP 7.0
  • PHP 7.1

Call one of the following commands to change the PHP Version:

$ changephp_5.6
$ changephp_7.0
$ changephp_7.1

This will change the PHP Version used by the Apache webserver as well as the Version of the php command.

You can also call the PHP versions directly using their full path

$ /usr/bin/php5.6 -v
$ /usr/bin/php7.0 -v
$ /usr/bin/php7.1 -v

Bei mir ist aber anscheinend die Php-version 5.9.9 installiert. (Nicht 5.6, nicht 7.0 und nicht 7.1)

Der Befehl $ vagrant -v funktioniert und sagt mir das ich die Vagrant-Version 1.9.2 installiert habe.

Die anderen Befehle, zum wechseln der php-Version funktionieren leider nicht.

$ changephp_7.1 liefert: command not found
$ /usr/bin/php7.1 -v liefert: no such file or directory 

Mit allen anderen php-Versionen hab ich die Befehle auch probiert. Mit gleichem Ergebnis.

Ich wäre wirklich sehr dankbar wenn mir da jemand weiterhelfen könnte.

Vielen Dank

Antworten

Anmelden oder Registrieren, um zu kommentieren.