weblabweblab MemberComments: 9 Received thanks: 0 Member since: July 2016

Guten Tag, 

in einem SW4-Projekt wird für Österreich ein eigener Steuersatz benötigt.

Sobald ein Kunde, dessen Adresse in Österreich eingetragen ist, sich einloggt, soll der für ihn gültige Steuersazu angezeigt werden. Dies geschieht aber nicht.

Im Listing werden zwar die richtigen Bruttopreise angezeigt, aber es erscheint nach wir vor der Text "inkl. 19% MwSt" die Zahl 19 wird im Template aus einer Smarty-Variable herausgelesen. Das bedeutet, dass hier der falsche Wert übertragen wird. Was machen wir falsch?

Hinzu kommt ein weiteres extrem eigenartiges Problem: Dass die Bruttopreise korrekt angezeigt werden, stimmt nur in fast alles Fällen. In einer bestimmten Kategorie im Shop-System gibt es hiermit Probleme. Hier weden dem eingeloggten Österreicher die deutschen Bruttopreise angezeigt. Klickt er dann aber auf Seite 2 der Produktauflistung, werden korrekt die österreichischen Bruttopreise angezeigt. Das ist aber nur bei dieser Kategorie. Das ist sehr unheimlich das Ganze. Was kann hier den Fehler verursachen?

Wir haben es recht eilig, weil ab Oktober das Ganze passen muss.

 

Vielen Dank für jeden Hinweis..

Viele Grüße.

Comments

  • weblabweblab MemberComments: 9 Received thanks: 0 Member since: July 2016

    Keiner eine Idee? :-/

     

  • SynonymousSynonymous MemberComments: 453 Received thanks: 75 Member since: July 2016

    Hast Du schon mal geprüft, ob das Snippet (Textelement) vielleicht irgendwo umgebogen wird? Wie sieht es aus, wenn Du das Originaltemplate lädst?

Sign In or Register to comment.