luckyred1871luckyred1871 MemberComments: 4 Received thanks: 0 Member since: October 2010 edited October 2010
Guten Abend,

ich habe Shopware zuletzt mit dem aktuellen Installationsscript installiert.

Wenn ich /backend/auth aufrufe und meine Zugangsdaten eingebe, erscheint der Ladebalken im Login-Fenster. Er lädt und lädt.. es passiert aber nichts weiter.
Ich habe auch den über das Installationsscript erstellten Admin-Zugang über einen SQL-Befehl hier aus dem Forum auf demo/demo zurückgesetzt, ohne Erfolg.

Die Fehlermeldung im Frontend besagt:
Ups! Ein Fehler ist aufgetreten!
Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

Keine gültige Lizenz gefunden in Shopware/Plugins/Default/Core/Shop/Bootstrap.php on line 68
Stack trace:
#0 Enlight/Event/EventHandler.php(60): Shopware_Plugins_Core_Shop_Bootstrap::onPreDispatch(Object(Enlight_Event_EventArgs))
#1 Enlight/Event/EventManager.php(70): Enlight_Event_EventHandler->execute('Shopware_Plugin...', Object(Enlight_Event_EventArgs))
#2 Enlight/Controller/Front.php(75): Enlight_Event_EventManager->notify(Object(Enlight_Event_EventArgs))
#3 Shopware/Bootstrap.php(21): Enlight_Controller_Front->dispatch('Enlight_Control...', Array)
#4 Enlight/Application.php(69): Shopware_Bootstrap->run()
#5 shopware.php(6): Enlight_Application->run()
#6 {main}
Eckdaten:
* Suse 11 m. Plesk 9.5.2
* PHP Version 5.2.14
* Zend Optimizer für PHP 5.2.x installiert und aktiviert
* Shopware Systemchecktool von heute besagt, dass ich alle Systemanforderung erfülle.
* In der DB in der Tabelle s_core_config sind die Einträge sHOST und sBASEPATH identisch im Format (subdomain.domain.tld), ebenso ist der Domainalias in der Tabelle s_core_multilingual eingefügt

Hinweis: ich habe unter gleicher Domain aber alter (mittlerweile gelöschter) Installation die Shopsoftware bereits lizensiert, aber dann Betriebssystem gewechselt. Der Server-Hostname hat sich geändert.

Viele Grüße,
Bernhard

Comments

  • Heiner LohausHeiner Lohaus MemberComments: 933 Received thanks: 272 Member since: June 2010
    Hallo,

    kannst du mir einmal einen Link zu deinen Shop schicken?
    Dann kann ich mir dort die Fehlermeldung anschauen.
    Dass in der Storefront die Meldung geworfen wird, das "Keine gültige Lizenz gefunden" wurde, ist normal. Du konntest ja bisher auch keine Lizenzen eintragen. ;)

    VG Heiner
  • luckyred1871luckyred1871 MemberComments: 4 Received thanks: 0 Member since: October 2010
    Rocky wrote:
    kannst du mir einmal einen Link zu deinen Shop schicken?
    [Edit]: Nach meinem 3. Beitrag konnte ich dir eine PN senden :)
  • Heiner LohausHeiner Lohaus MemberComments: 933 Received thanks: 272 Member since: June 2010
    Hi,

    das Problem ist bei dir fehlt die PHP-Extension "json":

    http://de3.php.net/manual/de/ref.json.php

    Diese ist eigentlich ein Grundbestandteil von PHP seit Version 5.2.
    Daher hast du wahrscheinlich bei dir die falsche PHP-Version am Laufen.
    Shopware benötigt mindesten die Version PHP 5.2.12:

    http://www.shopware.de/systemanforderungen/

    Viele Grüße Heiner
  • luckyred1871luckyred1871 MemberComments: 4 Received thanks: 0 Member since: October 2010
    Danke, Heiner!

    Ich hatte PHP Version 5.2.14 installiert (Auslieferungszustand Plesk 9.5.2). json war wohl nicht inbegriffen.

    Habe kurzerhand Debian + Plesk 9.5.2 installiert, ein Upgrade von PHP 5.2.6 auf PHP 5.3 durchgeführt, den Ioncube Loader installiert und in die zend_extension in der php.ini eingebunden.

    Hinweis: Die aktuelle check.php zeigt trotz korrekter Übertragung im binären Modus die Meldung "Dateien wurden nicht im Binarymode übertragen! Bitte führen Sie die Übertragung erneut durch!" an. Ich glaube die filesize im Skript ist nicht (mehr) korrekt.

    VG Bernhard
Sign In or Register to comment.