GeorgGeorg MemberComments: 4 Received thanks: 0 Member since: October 2010 edited October 2010
Hi!

Ich habe eine Frage zu den Textbausteinen. Wenn ich es richtig verstanden habe kann ich einzelne Begriffe im Frontend bequem über das Backend ändern.

Nehmen wir ein Beispiel:
Standartmäßig gibt es im unteren Bereich der Shop-Startseite den Begriff "Tagwolke". Diesen möchte ich in "Oft gesucht" ändern.

Dazu gehe ich im Backend in

Einstellungen -> Textbausteine -> Neue Templatebasis

und setze in das Suchefeld den Begriff "Tagwolke". Darauf wird mir folgender Baustein angezeigt:

frontend/plugins/index/tagcloud de_DE 1 TagcloudHead Tagwolke

Nun klicke ich auf den Stift um den Eintrag zu editieren und setze anstelle von "Tagwolke" den Begriff "Oft gesucht" ein und klicke auf speichern. Anschließend gehe ich auf

Einstellungen -> Shopcache leeren -> Alle markieren -> löschen

Nun lösche ich den Browsercache, schließe den Browser und rufe die Shopseite erneut auf. Jetzt sollte statt "Tagwolke" der Ausdruck "Oft gesucht" erscheinen. Statt dessen steht dort aber nach wie vor "Tagwolke".

Wenn ich mich erneut ins Backend einlogge und mir den entsprechenden Textbaustein ansehe ist hier aber meine Änderung übernommen worden. Hat jemand eine Idee was ich falsch mache?

Viele Grüße,
Georg

Comments

  • taauchertaaucher MemberComments: 1327 Received thanks: 137 Member since: October 2010
    Hallo georg,
    bei dir scheint ein anderes Problem vorzuliegen, deine Vorgehensweise ist richtig, es reicht aber, einfach den Cache der Textbausteine zu leeren, danach übernimmt er die neuen Sachen sofort.

    Was sagt denn deine Systeminfo unter Einstellungen?

    Grüße
    Frank
    Thanked by 1Georg
  • GeorgGeorg MemberComments: 4 Received thanks: 0 Member since: October 2010
    Hallo Frank!

    Vielen Dank für deine Antwort die mich auf meinen Fehler gebracht hat. Ich habe immer auf

    Einstellungen -> Shopcache leeren

    geklickt und dann in dem popup-Fenster alles markiert und gelöscht. Dank dir ist mir jetzt aufgefallen dass das Wort "Textbausteine" gar nicht dabei ist! Man muss nur mit der Maus auf

    Einstellungen -> Shopcache leeren

    und dann nach rechts weiter auf

    -> Textbausteine

    gehen. Ich dachte mit "Alles markieren" im popup-Fenster wäre auch tatsächlich alles gemeint. Jetzt funktioniert es perfekt.

    In der Systeminfo habe ich einen Eintrag gefunden:

    engine/connectors/api/tmp not writable

    Werde dieses Verzeichnis auf 777 setzen. Weißt du ob ich nur das Verzeichnis oder auch die evtl. darin befindlichen Dateien auf 777 setzen muss?

    Nochmal Danke,
    Georg
  • Stefan HeyneStefan Heyne ModeratorComments: 598 Received thanks: 163 Member since: June 2010
    Das Verzeichnis reicht, Du kannst aber auch nichts verkehrt machen, wenn Du die rechte rekursiv setzt. ;-)
Sign In or Register to comment.