itworksitworks MemberComments: 49 Received thanks: 5 Member since: July 2015 edited October 2015
Hallo,

ich benutze die Shopware Version 5.0.4 .

Ich habe das Plugin "individuelle Kategorien" gekauft, und habe inzwischen herausgefunden wie das Filtern nach Eigenschaften funktioniert.
Nämlich nicht wie in der Doku beschrieben, sondern z.B. so:
SwagCustomCategories?filterMode=props&id=333
Enttäuschend, dass für ein zu bezahlendes Plugin die Doku einfach falsch ist und der Kunde selbst erraten muss, wie beschriebene Funktionen laufen...

Nun aber zu meinem Problem:
Ich möchte eine solche URL für eine Unter-Kategorie verwenden.
D.h. ich wähle im linken Menü Kategorie 1, Unterkategorie 2, und dort ist eine weitere Unterkategorie mit einem externen Link a la /SwagCustomCategories?filterMode=props&id=333 versehen.
Wenn ich diesen nun aufrufe funktioniert das zwar, aber meine Kategorie-Navigation auf der linken Seite ist komplett zurückgesetzt. Der Kunde beginnt von vorn.

Gibt es eine Möglichkeit, den aktuellen Stand der Navigation bei Aufruf einer Unterkategorie mit externem Link zu behalten?
z.B. den Content nur im rechten Bereich anzuzeigen?

Dank und viele Grüße,
Florian

Comments

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 8572 Received thanks: 2538 Member since: September 2013
    Hallo,

    du kannst per ?c= die ID der Kategorie in der URL mit übergeben, dann wird das auch in der Navigation korrekt angezeigt. Wenn es mehrere Parameter mit ? sind, musst du das mit & verknüpfen.

    Generell wird das was das Plugin liefert ab Shopware 5.1.0 eine Core-Funktion 'Productstreams' mit deutlich mehr möglichkeiten, SEO-URLs und da kann auch direkt die Kategorienavigation verwendet werden ohne Parameter. Das Plugin wird also ab SW5.1 nicht mehr benötigt.

    Moritz
  • itworksitworks MemberComments: 49 Received thanks: 5 Member since: July 2015
    Das funktioniert, hervorragend, Dankeschön für die schnelle Antwort!
Sign In or Register to comment.