ShopwareianerShopwareianer MitgliedKommentare: 2875 Danke erhalten: 472 Mitglied seit: November 2013 bearbeitet Dezember 2015
Guten Morgen,

kann mir wer sagen, warum genau Shopware alle Artikel Bilder / Thumbnails über SSL lädt, obwohl SSL im Backend deaktiviert ist ?

Kommentare

  • SebastianKlöpperSebastianKlöpper AdministratorKommentare: 6857 Danke erhalten: 1559 Mitglied seit: Juni 2010
    Hallo,

    dann macht Shopware das im Standard auch nicht.
    Shopware stellt nur auf SSL um, wenn das speziell aktiviert wurde.

    Auch dann aber nur im Standard den Checkout Prozess, es sei denn, in den Grundeinstellungen ist eingestellt den ganzen Shop auf SSL zu stellen.

    Sind diese Optionen nicht eingestellt, so muss das Problem woanders liegen. Ggf. Anpassungen an Shopware Dateien (htaccess oder Template). Möglich ist auch das ein Plugin die Funktionen manipuliert.

    Sebastian
  • wschulzwschulz MitgliedKommentare: 2 Danke erhalten: 0 Mitglied seit: Dezember 2015
    Hallo, hab gerade das selbe Problem hier. Da es leider noch keine Lösung in diesem Thema gibt, schildere ich hier einmal genau mein Problem:

    Hab gerade Shopware 5.1.1 neu aufgespielt, inkl. Demodaten. Im Nachgang noch das Import/Export Advanced Modul.

    Erst danach hab ich das Frontend besucht. Leider werden hier keine Bilder angezeigt. Bei Rechtsklick auf die Platzhalterfelder und wählen von "Bild öffnen" wird versucht das Bild unter der https-Adresse abzurufen. Im Shop ist SSL aber nicht aktiviert. Auch wurde nichts am Template oder der .htaccess-Datei verändert. Es ist wie schon erwähnt eine frische Shopware-Installation mit Demodaten und dem Import/Export-Mod.

    Hier noch meine .htacess-Datei:
    <IfModule mod_rewrite.c>
    RewriteEngine on
    
    #RewriteBase /shopware/
    
    # Https config for the backend
    #RewriteCond %{HTTPS} !=on
    #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    
    RewriteRule shopware.dll shopware.php
    RewriteRule files/documents/.* engine [NC,L]
    RewriteRule backend/media/(.*) media/$1 [NC,L]
    
    RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/)
    RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/)
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ shopware.php [PT,L,QSA]
    
    # Fix missing authorization-header on fast_cgi installations
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
    </IfModule>
    
    <IfModule mod_alias.c>
        # Block access to VCS directories
        RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$)
    
        # Restrict access to root folder files
        RedirectMatch 404 /(composer\.(json|lock)|README\.md|UPGRADE\.md)$
    </IfModule>
    
    # Staging environment
    #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging
    
    # Development environment
    #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev
    #SetEnv SHOPWARE_ENV dev
    
    DirectoryIndex index.html
    DirectoryIndex index.php
    DirectoryIndex shopware.php
    
    # Disables download of configuration
    <Files ~ "\.(tpl|yml|ini)$">
        # Deny all requests from Apache 2.4+.
        <IfModule mod_authz_core.c>
              Require all denied
        </IfModule>
    
        # Deny all requests from Apache 2.0-2.2.
        <IfModule !mod_authz_core.c>
            Deny from all
        </IfModule>
    </Files>
    
    # Enable gzip compression
    <IfModule mod_deflate.c>
        AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json
    </IfModule>
    
    <Files ~ "\.(jpe?g|png|gif|css|js|woff|eot)$">
        <IfModule mod_expires.c>
            ExpiresActive on
            ExpiresDefault "access plus 1 month"
        </IfModule>
    
        <IfModule mod_headers.c>
            Header append Cache-Control "public"
            Header unset ETag
        </IfModule>
    
        FileETag None
    </Files>
    
    # Match generated files like:
    # 1429684458_t22_s1.css
    # 1429684458_t22_s1.js
    <FilesMatch "([0-9]{10})_(.+)\.(js|css)$">
        <ifModule mod_headers.c>
            Header set Cache-Control "max-age=31536000, public"
        </ifModule>
    
        <IfModule mod_expires.c>
            ExpiresActive on
            ExpiresDefault "access plus 1 year"
        </IfModule>
    </FilesMatch>
    
    # Disables auto directory index
    <IfModule mod_autoindex.c>
    	Options -Indexes
    </IfModule>
    
    <IfModule mod_negotiation.c>
        Options -MultiViews
    </IfModule>
    
    <IfModule mod_php5.c>
    #  php_value memory_limit 256M
    #  php_value max_execution_time 120
    #  php_value upload_max_filesize 20M
       php_flag phar.readonly off
       php_flag magic_quotes_gpc off
       php_flag session.auto_start off
       php_flag suhosin.session.cryptua off
       php_flag zend.ze1_compatibility_mode off
    </IfModule>
    
    #   AddType x-mapp-php5 .php
    #   AddHandler x-mapp-php5 .php
    
    <IfModule mod_headers.c>
        Header append X-Frame-Options SAMEORIGIN
    </IfModule>
    
    Falls jemand weiß wo das Problem liegt, helft mir bitte. Ich hab keinen Plan mehr woran es noch liegen könnte.

    Vielen Dank
    Wolfgang
  • meine-gute-stubemeine-gute-stube MitgliedKommentare: 74 Danke erhalten: 1 Mitglied seit: April 2013

    Hallo zusammen,

    habe gerade das gleiche Problem. Gibt es eine Lösung dafür?

  • kuborgh_hgiesenowkuborgh_hgiesenow MitgliedKommentare: 1 Danke erhalten: 0 Mitglied seit: 18. Mai

    Ich konnte das Problem auf eine fehlerhafte implementierung im Zusammenhang mit einem HTTP Proxy zurückführen: https://issues.shopware.com/issues/SW-18748

    Workaround ist: SSL *aktivieren* und einen beliebigen SSL Host eintragen, der sich vom normalen host unterscheidet.

Anmelden oder Registrieren, um zu kommentieren.