ICONICSICONICS MemberComments: 6 Received thanks: 1 Member since: March 2014 edited July 2014
Hallo zusammen,
ich habe genau das gleiche Problem wie hier beschrieben:
http://forum.shopware.de/administration-f55/artikeldetails-stammartikel-leer-nicht-editierbar-t18141.html
Einige Artikel sind nicht bearbeitbar. Klickt man auf den Bleistift, öffnet sich das Bearbeitungsformular, die darin befindlichen Felder sind allerdings leer und in der Titelzeile steht "neuer Artikel". Wie im genannten Thread auch beschrieben, erscheint die Javascript-Fehlermeldung:
Cannot read property '0' of null
var storeData = records[0];
Der Lösungsansatz in dem Thread ist, die Tabelle s_articles_similar zu leeren, was bei mir jedoch nichts bewirkt hat.

Kennt jemand noch einen anderen Lösungsansatz für das Problem?

Viele Grüße,
July

Comments

  • adrianradrianr MemberComments: 3 Received thanks: 0 Member since: March 2013
    Konnten Sie das Problem lösen? Habe den selben Fehler...
  • ICONICSICONICS MemberComments: 6 Received thanks: 1 Member since: March 2014
    adrianr wrote:
    Konnten Sie das Problem lösen? Habe den selben Fehler...
    Tut mir leid, ich habe bisher keine Lösung gefunden. Der Kunde hat die betroffenen Artikel gelöscht und neu eingegeben.
    Thanked by 1adrianr
  • artepartep MemberComments: 3586 Received thanks: 588 Member since: July 2010
    Das habe ich auch ab und zu mal. Dann schließe ich den Artikel und rufe ihn neu auf. Dann läd er es. Warum, wieso - bleibt ein Räsel.
  • kjkj MemberComments: 2 Received thanks: 1 Member since: May 2014
    Hatte das gleiche Problem.
    Die Ursache ist, dass dem Artikel ein ungültiger "Zubehör-Artikel" oder ein ungültiger "ähnlicher Artikel" zugewiesen ist. Das heisst es müssen die Tabellen s_articles_similar und s_articles_relationships manipuliert werden.
    In der Datenbank stellt sich das so dar, dass es zum Eintrag in der s_articles keinen zugeordneten Datensatz in s_articles_details gibt, wie das auch immer passieren kann.

    Ich lass folgende 2 SQL-Befehle laufen und danach funktioniert es wieder:

    delete from s_articles_relationships where relatedarticle in (select t1.id from s_articles as t1 left join s_articles_details as t2 on t1.id=t2.articleID where t2.articleID IS NULL);

    delete from s_articles_similar where relatedarticle in (select t1.id from s_articles as t1 left join s_articles_details as t2 on t1.id=t2.articleID where t2.articleID IS NULL);
    Thanked by 1SlashAlex
  • SlashAlexSlashAlex MemberComments: 2 Received thanks: 0 Member since: September 2018

    Danke

    hatte gleiche Problem.
    Gefixt manuell in s_articles_relationships Spalte.

    eine Relatedartikel (374) war nur mit einem Variant verbunden (AB000001.4)
    Hauptartikel und andere Varianten hatten ArticleID (1024).
    Sobald ich die Falsche Relatedartikel ID ersetzt habe - war das Problem behoben.
    ______________________________________________________

    Instruktionen:

    Machen Sie eine Suche in s_articles_details beim Ordernummer um entprechende Article ID zu finden.
    z.b Order AB000001 entspricht Article ID 574

    Dann suchen s_articles_relationships oder s_articles_similar bei diese Article ID Wert.

    Sie werden dann so was sehen

    id   articleID   relatedarticle
    14132   574   375
    14133   574   1024

    Dann checken Werte von Relatedarticle Spalte in s_articles_details und checken welche Ordernummer ist damit verbunden.
    Hauptartikel und Varianten - gut
    nur 1 Variant - Fehler.

Sign In or Register to comment.