great2gethergreat2gether MitgliedKommentare: 29 Danke erhalten: 7 Mitglied seit: Januar 2014 bearbeitet Februar 2015
Hallo liebes Shopware Forum,

kurze Frage: Ein Kunde bekommt bei seinem Shop extrem viele Spam Anmeldungen über das Newsletter Formular, wahrscheinlich über das Feld auf der Startseite.

Bei der Newsletter Registrierung wird bei mir kein Captcha Feld angezeigt, ist das normal? Wo kann ich das einschalten bzw. wie kann ich das nachträglich integrieren.

Es gibt ja einmal die Möglichkeit sich über das einzeilige Formular im Footer zu registrieren und dann noch über das richtige Formular wo man noch seinen Namen und die Adresse etc. eintragen kann. Notfalls würden wir das Formular aus dem Footer entfernen und dann bei dem ausführlichen Formular ein Captcha Feld einbauen wenn das möglich ist.

Ich hoffe ihr könnt mir weiter helfen - ich habe mir auch schon den Bereich Inhalte > Formulare einmal angeschaut aber da ist das Newsletter Formular auch nicht drin. Und im Forum konnte ich auch bisher nichts finden.

Vielen Dank im Voraus und Gruß aus Porz,
Atilla :shopware:

Kommentare

  • GesundwürzenGesundwürzen MitgliedKommentare: 264 Danke erhalten: 13 Mitglied seit: Februar 2015
    Hallo,

    ich schließe mich dem an. Kann man das captcha nachträglich einbauen oder aktivieren?
  • triloutrilou MitgliedKommentare: 17 Danke erhalten: 0 Mitglied seit: April 2015

    Hallo, ich wärme das Thema nochmals auf.

    Bekomme laufend Spam... blocken üner htaccess mühsam... die IPs ändern sich immer (alles aus Russland).

    Chapcha wäre sehr hilfreich. Danke im Voraus!!!

  • SebastianKlöpperSebastianKlöpper AdministratorKommentare: 6669 Danke erhalten: 1510 Mitglied seit: Juni 2010

    Hi,

    Suche? :-) https://forum.shopware.com/discussion/comment/183495/#Comment_183495

    Mit Plugin müsste man es aktuell noch lösen. 

    Sebastian

  • ToricToric MitgliedKommentare: 577 Danke erhalten: 18 Mitglied seit: Oktober 2015

    @SebastianKlöpper

    Die Eröffnungsfrage ist zwar schon sehr alt, aber das Problem habe ich seit einigen Monaten in der 5er Version. Tokenfehler werden produziert, weil ein Bot Newsletteranmeldungen oder Bewertungsabgaben versucht.

    Das Plugin habe ich jetzt mal getestet. Es scheint nur das Captcha bei der Registrierung möglich zu sein. In den anderen Punkten wohl nicht. Lasse mich aber gerne eines Besseren belehren, wenn jemand eine Möglichkeit findet.

  • SebastianKlöpperSebastianKlöpper AdministratorKommentare: 6669 Danke erhalten: 1510 Mitglied seit: Juni 2010

    Hi,

    korrekt - das Plugin ist für die Registrierung gedacht.

    Bzgl. der Tokens generell hat es einige Verbesserungen im letzten Update gegeben. Mein Frage wäre daher, ob das bei dir in den aktuellsten Versionen noch auftritt?

    Sebastian

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 3857 Danke erhalten: 1006 Mitglied seit: September 2013

    Bots erzeugen weiterhin eine Fehlermeldung, wenn diese versuchen das Newsletter-Formular abzuschicken. Das ist auch völlig legitim und auch so gewollt. Die Meldung kann dann einfach ignoriert werden. Hintergrund ist hier, dass man nicht jeden Bot zuverlässig identifizieren kann. Bevor man also eine Fehlermeldung "verschluckt" die ggf. wichtig ist, haben wir uns dazu enstchieden hier keine Einschränkung zu machen.

  • ToricToric MitgliedKommentare: 577 Danke erhalten: 18 Mitglied seit: Oktober 2015

    Sebastian, ich werde das im Auge behalten. Das Update auf 5.2.13 habe ich noch nicht gemacht. Ich hatte zwischenzeitlich die Fehlermails abgeschaltet, da es lästig war. Allerdings vergisst man dann auch zu schauen, ob es überhaupt Fehler gab.

    Moritz, soweit klar. Da diese Meldungen im Verdacht standen, die CPU-Belastung auszureizen, hat mich das Plugin interessiert. Möglicherweise war die Ursache aber eine andere. Wäre zu schön, wenn Bots lernfähig wären und es irgendwann mal aufgeben :-)

  • simplybecausesimplybecause MitgliedKommentare: 1006 Danke erhalten: 108 bearbeitet 2. April Mitglied seit: Januar 2012

    Uns hat es seit gestern auch erwischt.
    Ich hab jetzt mehr als 50 unterschiedliche IP-Adressen ausfindig gemacht, die mehr als 400 E-Mail-Adressen in das Nesletter-Formular eingegeben haben.
    Von den 400 Adressen sind bisher allerdings nicht mal 10 Fehlermeldungen gekommen, dass es die E-Mail-Adressen nicht gibt.
    Hat jemand eine Idee, wie wir das unterbinden können?
     

  • ToricToric MitgliedKommentare: 577 Danke erhalten: 18 Mitglied seit: Oktober 2015

    simplybecause Wie ist das möglich? Habt ihr den Token deaktiviert? Ich bekomme normalerweise nur die Fehlermails, aber es gibt keine wirklichen Einträge.

  • simplybecausesimplybecause MitgliedKommentare: 1006 Danke erhalten: 108 bearbeitet 2. April Mitglied seit: Januar 2012

    Ja, der ist deaktiviert.
    Hab ihn jetzt mal wieder aktiviert. Mal gucken, was passiert.

  • dewibdewib MitgliedKommentare: 76 Danke erhalten: 2 bearbeitet 19. April Mitglied seit: November 2013

    Ich muss diesen Thread mal "zurück" bringen. Er ist ja ursprünglich in "SW4" gepostet. Die letzten Beiträge zur Problemlösung mittels CSRF Token beziehen sich allerdings schon auf SW5. Ich setze noch SW 4.3.6 ein und habe seit einiger Zeit das Problem der massenhaften Bot-Anmeldungen im Newsletter. Wie kann das in SW4 verhindert werden?

  • Moritz NaczenskiMoritz Naczenski AdministratorKommentare: 3857 Danke erhalten: 1006 Mitglied seit: September 2013

    In Shopware 4 musst du dir eine eigene Lösung erstellen, ggf. indem du dort ein Captcha implementierst.

    Generell gibt es da erstmal nichts, was das abfangen würde.

  • dewibdewib MitgliedKommentare: 76 Danke erhalten: 2 Mitglied seit: November 2013

    Ich krieg's nicht hin... ein Captcha beim Newsletter-Feld im Footer ist ja auch aus Platz- und Design/Optik-Gründen äußert schwierig. Hat hier jemand nen Ansatz wie das sonst noch zu lösen wäre das Problem?

Anmelden oder Registrieren, um zu kommentieren.