patrickwehpatrickweh MitgliedKommentare: 11 Danke erhalten: 0 Mitglied seit: Dezember 2013 bearbeitet 15. Januar
Moin zusammen,

ich entwickle gerade an einer Schnittstelle zwischen unserer Warenwirtschaft und einer Shopware Lösung.
Leider bin ich da auf ein Problem gestoßen bei dem ich einfach nicht weiter komme.

1. Wenn ich einen Artikel ohne Varianten habe und diesem ein Bild zuweise wird dieses Bild bei jedem Update wieder zugewiesen so dass der Artikel am ende das gleiche Bild X mal hat. Lasse ich das image Objekt leer wird die Zuordnung komplett entfernt.

2. Bei Varianten habe ich keine Ahnung wie ich den Varianten überhaupt Bilder zuordnen kann und finde auch nirgends Beispiele oder Tutorials dafür.

Zum ersten Problem habe ich hier im Forum schon einen Post gefunden, leider hat der Kollege abschließend nur geschrieben: »Habs hinbekommen, danke« aber nicht wie er es hinbekommen hat :-/

wäre super wenn mir da jemand einen Hinweis hätte :-)

Gruß

Patrick

Kommentare

  • edinedin MitgliedKommentare: 183 Danke erhalten: 11 Mitglied seit: Juni 2013
    Hi Patrick,

    zu 2. geht das wohl bisher nicht (siehe: post76431.html#p76431).
    Man kann per API die Bilder nur einem Artikel zuordnen, aber nicht den einzelnen Varianten. Es wird derzeit auf die Import Schnittstelle im Backend verwiesen, aber dann kann man ja REST API Import komplett aufgeben. Hoffentlich ändert sich das bald.

    zu 1. kann ich nur Vermutungen anstellen, habe nämlich keine updates getestet. Ich vermute aber dass du in dein update array lediglich Elemente einfügen sollst, die auch upgedatet werden sollen. Also dein Bild Array Element soll nicht leer sein, es darf gar nicht vorhanden sein, sonst überschreibst du es mit einem neuen Wert, nämlich leer bzw. kein Bild.

    Sag bescheid obs geklappt hat.

    Gruß Edin
    Danke von 1patrickweh
  • patrickwehpatrickweh MitgliedKommentare: 11 Danke erhalten: 0 Mitglied seit: Dezember 2013
    edin schrieb:
    zu 2. geht das wohl bisher nicht (siehe: post76431.html#p76431).
    Man kann per API die Bilder nur einem Artikel zuordnen, aber nicht den einzelnen Varianten. Es wird derzeit auf die Import Schnittstelle im Backend verwiesen, aber dann kann man ja REST API Import komplett aufgeben.
    hmmmm, das ist garnicht gut… Insgesamt lässt die Api was Varianten angeht ja sehr zu wünschen übrig, aber das ist natürlich ganz besonders bescheiden.
    Damit wäre die Api fast schon nutzlos für mich… wäre ne Katastrophe :-/
    edin schrieb:
    zu 1. kann ich nur Vermutungen anstellen, habe nämlich keine updates getestet. Ich vermute aber dass du in dein update array lediglich Elemente einfügen sollst, die auch upgedatet werden sollen. Also dein Bild Array Element soll nicht leer sein, es darf gar nicht vorhanden sein, sonst überschreibst du es mit einem neuen Wert, nämlich leer bzw. kein Bild.
    *Facepalm* da hätte ich drauf kommen können, klappt super vielen Dank!
    Aber besonders schön ist das auch nicht, wenn ich per ID ein Bild an einem Artikel angebe würde ich erwarten dass das Bild nur 1x zugeordnet wird und nicht immer wieder :o

    Gruß

    Patrick
  • edinedin MitgliedKommentare: 183 Danke erhalten: 11 Mitglied seit: Juni 2013
    Ja, ich hoffe dass sich durch 4.2 sich einiges und das Upsdate bald verfügbar ist. Immerhin wird auf der Preview Seite die Verbesserung im API Bereich versprochen.
    Abwarten und hoffen, wenn mann sich das zeitlich erlauben kann :)

    Viele Grüße, Edin
  • omecoomeco MitgliedKommentare: 9 Danke erhalten: 0 Mitglied seit: Dezember 2013
    Hallo Patrick,

    wir setzen uns in der Sache einmal mit dem Shopware Support in Verbindung und klären, ob es einen Workaround gibt oder wir auf die 4.2 warten müssen.

    Viele Grüße - Lars
  • timmeyytimmeyy MitgliedKommentare: 34 Danke erhalten: 3 Mitglied seit: 11. Januar
    **PUSH
    Gab es einen Workaround?
  • NeoxxNeoxx MitgliedKommentare: 640 Danke erhalten: 121 Mitglied seit: Mai 2014
    Artikelbilder:

    Das gleiche Problem hatten wir auch.
    Es entsteht, weil die API die Media-ID nicht zurück gibt nach dem Upload. Somit kann man ein Bild nie ordentlich aktualisieren, da der WWS die Zuordnung fehlt. Es wir bei jeder Übertragung das Bild nochmals im Artikel angelegt. (Woher soll SW auch wissen, dass dies nur ein update ist?)
    Gelöst haben wir dies über ein Plugin, welches die API dahingehend erweitert, dass Bilddaten von einem Artikel bei der Übertragung mit Bild zuerst gelöscht werden und dannach neu zugeordnet.

    Edit: Mittlerweile haben wir eine API-Erweiterung für Medien uns programmieren lassen die selbstständig die Bilder anhand einer Ähnlichkeit zuordnet.

    Grüße
Anmelden oder Registrieren, um zu kommentieren.